summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-24 22:10:11 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:30 +0200
commite845c148ed3d524392845f08c98b16ebd37b478d (patch)
tree9e1b57b39f3058b613ca37a817a26c0b40ae0b17
parent168a92e0c070808e6d3d5fdc6a65a4139338cef1 (diff)
downloadpatches-e845c148ed3d524392845f08c98b16ebd37b478d.tar
patches-e845c148ed3d524392845f08c98b16ebd37b478d.tar.gz
gnu: Add rust-rayon-0.8.
* gnu/packages/crates-io.scm (rust-rayon-0.8): New variable.
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8c5ec2f0bd..6edee04bda 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18164,6 +18164,28 @@ accessors.")
("rust-serde" ,rust-serde-1.0)
("rust-serde-derive" ,rust-serde-derive-1.0))))))
+(define-public rust-rayon-0.8
+ (package/inherit rust-rayon-1.3
+ (name "rust-rayon")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rayon" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1j2l9x98ma63qkh9w8zik0vcpwqf9cvc2ynh66ibjp36nq4gw55n"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-rayon-core" ,rust-rayon-core-1.7))
+ #:cargo-development-inputs
+ (("rust-compiletest-rs" ,rust-compiletest-rs-0.2)
+ ("rust-docopt" ,rust-docopt-0.7)
+ ("rust-futures" ,rust-futures-0.1)
+ ("rust-rand" ,rust-rand-0.3)
+ ("rust-rustc-serialize" ,rust-rustc-serialize-0.3))))))
+
(define-public rust-rayon-core-1.7
(package
(name "rust-rayon-core")