summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-24 21:58:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:16 +0200
commitd1c18f44c2d5a385926ffa3960af8417e1b792d0 (patch)
tree33a64c867ace2cadb7c60b50796250d570073530
parent59e2f5dbe624039e421e44dd386d7785c657f1d3 (diff)
downloadpatches-d1c18f44c2d5a385926ffa3960af8417e1b792d0.tar
patches-d1c18f44c2d5a385926ffa3960af8417e1b792d0.tar.gz
gnu: Add rust-derive-new-0.5.
* gnu/packages/crates-io.scm (rust-derive-new-0.5): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 103c99b066..63d7eeaaa0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4922,6 +4922,29 @@ and arithmetic.")
(description "Demo of proc-macro-hack.")
(license (list license:expat license:asl2.0))))
+(define-public rust-derive-new-0.5
+ (package
+ (name "rust-derive-new")
+ (version "0.5.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "derive-new" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ncibp4jhpkym7namg3viqyw8hljd32n6abg64af8qjwrn91iwvi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1.0)
+ ("rust-quote" ,rust-quote-1.0)
+ ("rust-syn" ,rust-syn-1.0))))
+ (home-page "https://github.com/nrc/derive-new")
+ (synopsis "Simple constructor functions for structs and enums")
+ (description "`#[derive(new)]` implements simple constructor functions for
+structs and enums.")
+ (license license:expat)))
+
(define-public rust-diff-0.1
(package
(name "rust-diff")