summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-20 22:33:09 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:45 +0200
commitcfb9bc26cc1d6d239e837dcb7423045c0d4fadec (patch)
treeedf57576e2d7c9f8b45362aeb53f1a3ff04c3228
parent1431405e3fd5fdb31d01245d4e43815c90914021 (diff)
downloadpatches-cfb9bc26cc1d6d239e837dcb7423045c0d4fadec.tar
patches-cfb9bc26cc1d6d239e837dcb7423045c0d4fadec.tar.gz
gnu: Add rust-zbase32-0.1.
* gnu/packages/crates-io.scm (rust-zbase32-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e34135cab9..a0be3575b8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27443,6 +27443,29 @@ to XDG Base Directory specification")
(("rust-clippy" ,rust-clippy-0.0)
("rust-linked-hash-map" ,rust-linked-hash-map-0.3))))))
+(define-public rust-zbase32-0.1
+ (package
+ (name "rust-zbase32")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "zbase32" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0gz3nmiaidscb5c85rh3qxi8i584gz5xm3amlxqminl8jq27k40g"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ;; dependency cypthon not yet availalbe
+ #:cargo-development-inputs
+ (;; ("rust-cpython" ,rust-cpython-0.2) TODO
+ ("rust-quickcheck" ,rust-quickcheck-0.7)
+ ("rust-rand" ,rust-rand-0.6))))
+ (home-page "https://gitlab.com/pgerber/zbase32-rust")
+ (synopsis "Implementation of zbase32")
+ (description "This package provides an implementation of zbase32.")
+ (license license:lgpl3+)))
+
(define-public rust-zip-0.5
(package
(name "rust-zip")