summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 17:02:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:29 +0100
commitacb75c0328eccf30a3683a76d2bfed7ee5cfa9ed (patch)
treeb69e241e08abccbd4feb391c2523fd21a7441ed1
parentd1c4f329d102ada27586a3430257d5c1e8d93b6b (diff)
downloadpatches-acb75c0328eccf30a3683a76d2bfed7ee5cfa9ed.tar
patches-acb75c0328eccf30a3683a76d2bfed7ee5cfa9ed.tar.gz
gnu: python-pycparser: Use INVOKE.
* gnu/packages/python-xyz.scm (python-pycparser)[arguments]: Unconditionally return #T from "check" phase.
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae12cfba0c..9c74e2b5f8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3805,7 +3805,8 @@ a general image processing tool.")
(replace 'check
(lambda _
(with-directory-excursion "tests"
- (zero? (system* "python" "all_tests.py")))))
+ (invoke "python" "all_tests.py"))
+ #t))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((data (string-append (assoc-ref outputs "doc") "/share"))