summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-19 15:48:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-22 23:39:31 +0200
commita9a279b6af2969b33659ed65d0ca8878354cedd4 (patch)
tree378e4e6bd74e02281e39ff9d76e4190711b10897
parent7473d73ed09d7d614d111454c9acbffdf2b86c3d (diff)
downloadpatches-a9a279b6af2969b33659ed65d0ca8878354cedd4.tar
patches-a9a279b6af2969b33659ed65d0ca8878354cedd4.tar.gz
gnu: Add rust-inflate-0.4.
* gnu/packages/crates-io.scm (rust-inflate-0.4): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 21c40cd93a..fd4563489b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6107,6 +6107,27 @@ This crate was initially published under the name ordermap, but it was
renamed to indexmap.")
(license (list license:expat license:asl2.0))))
+(define-public rust-inflate-0.4
+ (package
+ (name "rust-inflate")
+ (version "0.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "inflate" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zxjdn8iwa0ssxrnjmywm3r1v284wryvzrf8vkc7nyf5ijbjknqw"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-adler32" ,rust-adler32-1.0))))
+ (home-page "https://github.com/PistonDevelopers/inflate.git")
+ (synopsis "DEFLATE decoding")
+ (description "This package provides DEFLATE decoding.")
+ (license license:expat)))
+
(define-public rust-insta-0.8
(package
(name "rust-insta")