summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-20 22:52:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:27 +0200
commita74ece550aaccb695de0826823f5dc4d7b4e99c9 (patch)
treef4995c1c33beaf621d2bfe832231e22b128461b4
parentbfe36370cdfa653600d2b662f23811a35c79e852 (diff)
downloadpatches-a74ece550aaccb695de0826823f5dc4d7b4e99c9.tar
patches-a74ece550aaccb695de0826823f5dc4d7b4e99c9.tar.gz
gnu: Add rust-lru-cache-0.1.
* gnu/packages/crates-io.scm (rust-lru-cache-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5bfeb57a05..242140364d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11903,6 +11903,28 @@ by inspecting the system for user preference.")
("rust-serde-derive" ,rust-serde-derive-1.0)
("rust-serde-json" ,rust-serde-json-1.0))))))
+(define-public rust-lru-cache-0.1
+ (package
+ (name "rust-lru-cache")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lru-cache" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "071viv6g2p3akwqmfb3c8vsycs5n7kr17b70l7la071jv0d4zqii"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-heapsize" ,rust-heapsize-0.4)
+ ("rust-linked-hash-map" ,rust-linked-hash-map-0.5))))
+ (home-page "https://github.com/contain-rs/lru-cache")
+ (synopsis "Cache that holds a limited number of key-value pairs")
+ (description "This package provides a cache that holds a limited number of
+key-value pairs.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-lscolors-0.6
(package
(name "rust-lscolors")