summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-08 12:19:11 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:19 +0200
commita4b6242f026909e6c678d58f0d4e58757b3984d3 (patch)
treee1f2621d51ebd907f55e8a3521b1ce21bcd23e90
parentb8faa13edd12741f715784f7523cc3927adfee3c (diff)
downloadpatches-a4b6242f026909e6c678d58f0d4e58757b3984d3.tar
patches-a4b6242f026909e6c678d58f0d4e58757b3984d3.tar.gz
gnu: Add rust-dogged-0.2.
* gnu/packages/crates-io.scm (rust-dogged-0.2): New variable.
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 188a3eb526..3d451923cc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5390,6 +5390,31 @@ from macros.")
parameters, associated types, and type constraints.")
(license (list license:expat license:asl2.0))))
+(define-public rust-dogged-0.2
+ (package
+ (name "rust-dogged")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dogged" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0yk5l6qqidl5y935x15gi9kkd6niim1wb64r1l7kdzl9jw8dyf16"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-development-inputs
+ (("rust-rand" ,rust-rand-0.3))))
+ (home-page "https://github.com/nikomatsakis/dogged")
+ (synopsis "Persistent vector, similar to Clojure")
+ (description "This package experimental persistent collections in Rust.
+Based on a digit-indexed trie, as in Clojure. Supports @code{push()},
+@code{get()}, and @code{get_mut()} as its primitive operations for now. All
+O(1)-in-practice, if not in theory, but obviously not as fast as a
+non-persistent vector.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-draw-state-0.8
(package
(name "rust-draw-state")