summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-25 12:12:29 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:34 +0200
commit9bc97f1259efb2807c8217be465aa8ca21cbac6c (patch)
treea07be5086531d5203ad56e24b45e8908610d2ca1
parentb469d7e58f6e6016347f26ad11dba04799a69692 (diff)
downloadpatches-9bc97f1259efb2807c8217be465aa8ca21cbac6c.tar
patches-9bc97f1259efb2807c8217be465aa8ca21cbac6c.tar.gz
gnu: Add rust-rustls-0.12.
* gnu/packages/crates-io.scm (rust-rustls-0.12): New variable.
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9a68752ac3..017cbb0697 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19442,6 +19442,38 @@ rustc compiler.")
(description "This package provides a modern TLS library written in Rust.")
(license (list license:asl2.0 license:isc license:expat))))
+(define-public rust-rustls-0.12
+ (package/inherit rust-rustls-0.16
+ (name "rust-rustls")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustls" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1k8b8cc0pjkv5cxdgs43jif7nslzsxair9b2sifgvjag7a4f8wmb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ;; 1/45 tests fails due to some missing file
+ #:cargo-inputs
+ (("rust-base64" ,rust-base64-0.9)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-ring" ,rust-ring-0.13)
+ ("rust-sct" ,rust-sct-0.3)
+ ("rust-untrusted" ,rust-untrusted-0.6)
+ ("rust-webpki" ,rust-webpki-0.18))
+ #:cargo-development-inputs
+ (("rust-ct-logs" ,rust-ct-logs-0.3)
+ ("rust-docopt" ,rust-docopt-0.8)
+ ("rust-env-logger" ,rust-env-logger-0.4)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-mio" ,rust-mio-0.6)
+ ("rust-regex" ,rust-regex-0.2)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-derive" ,rust-serde-derive-1.0)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.14))))))
+
(define-public rust-rusttype-0.8
(package
(name "rust-rusttype")