summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-08 12:06:07 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 10:17:01 +0200
commit85ab6fd85339b7ea934d822d5f5d08453afceb35 (patch)
tree1a53326cf5f554dcb0249901e1e7fb8d3ac3a12f
parent8cc67deab3224de96125b72bb82a7f244a5332be (diff)
downloadpatches-85ab6fd85339b7ea934d822d5f5d08453afceb35.tar
patches-85ab6fd85339b7ea934d822d5f5d08453afceb35.tar.gz
gnu: Add rust-ascii-canvas-2.
* gnu/packages/crates-io.scm (rust-ascii-canvas-2): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1e4ccb7ea2..8c7649f496 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;;
@@ -847,6 +848,31 @@ standard library.")
("rust-serde" ,rust-serde-1.0)
("rust-serde-test" ,rust-serde-test-1.0))))))
+(define-public rust-ascii-canvas-2
+ (package
+ (name "rust-ascii-canvas")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ascii-canvas" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0a9s8vrbc5jr6ry5ygjyfqmbs9gyya1v6dsxzsczpai8z4nvg3pz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ;; TODO: failes due to an unresolved import
+ #:cargo-inputs
+ (("rust-term" ,rust-term-0.5))))
+ (home-page "https://github.com/nikomatsakis/ascii-canvas")
+ (synopsis "Simple canvas for drawing lines and styled text and emitting to
+the terminal")
+ (description "@code{ASCII} canvas is a simple Rust library that allows you
+to draw lines and colored text and then write them to the terminal. It uses
+the term library to handle the ANSI nonsense and hence it works on Windows,
+Mac, and Unix.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-assert-matches-1.3
(package
(name "rust-assert-matches")