summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-03 01:37:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-03 01:37:38 +0100
commit6bb5f88e1d8cb9aa2bbda1e4866423f86c634ffc (patch)
tree490ea36aa6940283f10ad41c0ca41622a6968596
parent7f055a0a3748e46419053405f5f120cf2df1968d (diff)
downloadpatches-6bb5f88e1d8cb9aa2bbda1e4866423f86c634ffc.tar
patches-6bb5f88e1d8cb9aa2bbda1e4866423f86c634ffc.tar.gz
gnu: Add guile-picture-language.
* gnu/packages/guile-xyz.scm (guile-picture-language): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 5c6a6c7e0b..77d117f248 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1839,3 +1839,27 @@ format is also supported.")
(define-public mcron2
;; This was mthl's mcron development branch, and it became mcron 1.1.
(deprecated-package "mcron2" mcron))
+
+(define-public guile-picture-language
+ (let ((commit "1531116036d1b5e0d2482ff2c8d77ad21f1d2bef")
+ (revision "1"))
+ (package
+ (name "guile-picture-language")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.elephly.net/software/guile-picture-language.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "04salmqf5x84vb3qkkxx47b64jyl290zsf3ik81l9hg6fwvvlmq3"))))
+ (build-system guile-build-system)
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (home-page "https://git.elephly.net/software/guile-picture-language.git")
+ (synopsis "Picture language for Guile")
+ (description
+ "This package provides a simple SVG-based picture language for Guile.
+The picture values can directly be displayed in Geiser.")
+ (license license:lgpl3+))))