summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-08 12:34:05 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:35 +0200
commit60d19eca1f74b024d8ae982a873b43de10cb057e (patch)
tree9c43323fbd9dd2e7c57fd8018c91dc41a14350ef
parent86eb83b288b01a8125fb23c4413788c61da3a70f (diff)
downloadpatches-60d19eca1f74b024d8ae982a873b43de10cb057e.tar
patches-60d19eca1f74b024d8ae982a873b43de10cb057e.tar.gz
gnu: Add rust-sha2-asm-0.5.
* gnu/packages/crates-io.scm (rust-sha2-asm-0.5): New variable.
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 055a53c22a..b06baa623f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20889,6 +20889,27 @@ for the serde framework.")
"Assembly implementation of SHA-1 compression function.")
(license license:expat)))
+(define-public rust-sha2-asm-0.5
+ (package
+ (name "rust-sha2-asm")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sha2-asm" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0k3qwv2yl8fyi2i6cprfb8d874ii5kmcmckgnjkwnz2ac9fayyl1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cc" ,rust-cc-1.0)))) ;; build dependency
+ (home-page "https://github.com/RustCrypto/asm-hashes")
+ (synopsis "Assembly implementation of SHA-2")
+ (description "This package provides an assembly implementations of hash
+functions core functionality.")
+ (license license:expat)))
+
(define-public rust-shader-version-0.6
(package
(name "rust-shader-version")