summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-19 21:59:17 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:37 +0200
commit5db08ef460a1f63763bcf8c9f9bf531ed17692db (patch)
tree0102d56605fb142bae2c7e4916a6d3333327aa77
parent3e76f5eb8274ae9ea5ca348011db3830dbfeff03 (diff)
downloadpatches-5db08ef460a1f63763bcf8c9f9bf531ed17692db.tar
patches-5db08ef460a1f63763bcf8c9f9bf531ed17692db.tar.gz
gnu: Add rust-string-0.2.
* gnu/packages/crates-io.scm (rust-string-0.2): New variable.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 72e259a107..d201476337 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22027,6 +22027,26 @@ crate.")
(license (list license:unlicense
license:expat))))
+(define-public rust-string-0.2
+ (package
+ (name "rust-string")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "string" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0vaxz85ja52fn66akgvggb29wqa5bpj3y38syykpr1pbrjzi8hfj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bytes" ,rust-bytes-0.4))))
+ (home-page "https://github.com/carllerche/string")
+ (synopsis "UTF-8 encoded string with configurable byte storage")
+ (description "This package provides a UTF-8 encoded string with
+configurable byte storage.")
+ (license license:expat)))
+
(define-public rust-string-cache-0.7
(package
(name "rust-string-cache")