summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-19 21:48:16 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:23 +0200
commit5ac71eda18b9e80e1acbb9e102c3a4bb95c5ad03 (patch)
treeeb4dd829ca5c97e3a75b3cf58c4106c74ce44b45
parent2380285bd1b98f049c874e5bf6fee023d32dd6ca (diff)
downloadpatches-5ac71eda18b9e80e1acbb9e102c3a4bb95c5ad03.tar
patches-5ac71eda18b9e80e1acbb9e102c3a4bb95c5ad03.tar.gz
gnu: Add rust-http-body-0.3.
* gnu/packages/crates-io.scm (rust-http-body-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f206977de4..fdedaf28c8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9826,6 +9826,29 @@ requests and responses.")
("rust-serde" ,rust-serde-1.0)
("rust-serde-json" ,rust-serde-json-1.0))))))
+(define-public rust-http-body-0.3
+ (package
+ (name "rust-http-body")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "http-body" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "06qi0ni45lb92w3ml260c0bxbq5zd4snjmz0a9k69xq6021zzm8k"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ;; FIXME requires Rust >= 1.39 for building
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-0.5)
+ ("rust-http" ,rust-http-0.2))))
+ (home-page "https://github.com/hyperium/http-body")
+ (synopsis "Asynchronous, streaming, HTTP request or response body")
+ (description "Trait representing an asynchronous, streaming, HTTP request
+or response body.")
+ (license license:expat)))
+
(define-public rust-http-req-0.5
(package
(name "rust-http-req")