summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-25 12:46:18 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:16 +0200
commit59e2f5dbe624039e421e44dd386d7785c657f1d3 (patch)
tree8e5f2d211166eb623ed7553661166481f131bd3b
parent7bfde108d4fa84c3d1ec1e613acc62fc39a1a803 (diff)
downloadpatches-59e2f5dbe624039e421e44dd386d7785c657f1d3.tar
patches-59e2f5dbe624039e421e44dd386d7785c657f1d3.tar.gz
gnu: Add rust-ct-logs-0.3.
* gnu/packages/crates-io.scm (rust-ct-logs-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4d609120ef..103c99b066 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4533,6 +4533,27 @@ Code} (MAC) algorithms.")
"Bare bones CSV parsing with no_std support.")
(license (list license:unlicense license:expat))))
+(define-public rust-ct-logs-0.3
+ (package
+ (name "rust-ct-logs")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ct-logs" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1f0885ws3p49xh6dfgnhh7zjw9h4rhs9ljs8i9cnkhifzz98784f"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-sct" ,rust-sct-0.3))))
+ (home-page "https://github.com/ctz/ct-logs")
+ (synopsis "Google's list of Certificate Transparency logs")
+ (description "This package contains Google's list of Certificate
+Transparency logs for use with sct crate.")
+ (license (list license:asl2.0 license:isc license:expat))))
+
(define-public rust-ctor-0.1
(package
(name "rust-ctor")