summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-24 23:19:22 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:37 +0200
commit3e76f5eb8274ae9ea5ca348011db3830dbfeff03 (patch)
tree4132442cdd8732f6fad888df67022d666b5e7e80
parent20505910c97a6eafeef2134412d0575a08dbe60d (diff)
downloadpatches-3e76f5eb8274ae9ea5ca348011db3830dbfeff03.tar
patches-3e76f5eb8274ae9ea5ca348011db3830dbfeff03.tar.gz
gnu: Add rust-spmc-0.3.
* gnu/packages/crates-io.scm (rust-spmc-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 32e29a8f65..72e259a107 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21665,6 +21665,27 @@ initializers are available.")
"07ywqn1vrpi3c43fmvsx7pawk9h3rb77yyqbnhap2micl454kb6f"))))
(arguments '(#:skip-build? #t))))
+(define-public rust-spmc-0.3
+ (package
+ (name "rust-spmc")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "spmc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1rgcqgj6b3d0cshi7277akr2xk0cx11rkmviaahy7a3pla6l5a02"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ;; tests hang
+ #:cargo-development-inputs
+ (("rust-loom" ,rust-loom-0.2))))
+ (home-page "https://github.com/seanmonstar/spmc")
+ (synopsis "Simple SPMC channel")
+ (description "Simple SPMC channel")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-spsc-buffer-0.1
(package
(name "rust-spsc-buffer")