summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-27 20:44:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:58:43 +0100
commit3719d0edf2ecbcad7cb155548927004bc64cfc97 (patch)
tree6d95a37413741b8f4b1eaf6df08196673a860383
parent9c77852e1948f21b62932e073bad49c7bc65b614 (diff)
downloadpatches-3719d0edf2ecbcad7cb155548927004bc64cfc97.tar
patches-3719d0edf2ecbcad7cb155548927004bc64cfc97.tar.gz
gnu: python-sphinx@1.6: Add python2 variant.
* gnu/packages/python.scm (python-sphinx-1.6)[properties]: Declare python2 variant. (python2-sphinx-1.6): New public variable.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8285a4ea3c..5c6bc7f04e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2412,7 +2412,17 @@ sources.")
`(("python-pytest" ,python-pytest)
("imagemagick" ,imagemagick) ; for "convert"
,@(package-native-inputs python-sphinx)))
- (properties '())))
+ (properties `((python2-variant . ,(delay python2-sphinx-1.6))))))
+
+(define-public python2-sphinx-1.6
+ (let ((base (package-with-python2 (strip-python2-variant python-sphinx-1.6))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python2-typing" ,python2-typing)
+ ,@(package-propagated-inputs base)))
+ (native-inputs `(("python2-enum34" ,python2-enum34)
+ ,@(package-native-inputs base))))))
(define-public python-sphinx-1.5.3
(package