summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-08 12:15:02 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:19 +0200
commit33bfe341a227009b76a6a5486730db8c3582a47c (patch)
treef7f7cf832391ee2ce529506a38b00dff10837dc6
parent8c241c4d0bdb18e79767e88dbf864fc7f75b6888 (diff)
downloadpatches-33bfe341a227009b76a6a5486730db8c3582a47c.tar
patches-33bfe341a227009b76a6a5486730db8c3582a47c.tar.gz
gnu. Add rust-ena-0.13.
* gnu/packages/crates-io.scm (rust-ena-0.13): New variable.
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 05183f5469..fc7d275608 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5651,6 +5651,30 @@ floating-point primitives to an @code{io::Write}.")
inclusion of Windows resources in the most resilient fashion imaginable.")
(license license:expat)))
+(define-public rust-ena-0.13
+ (package
+ (name "rust-ena")
+ (version "0.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ena" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0dkggq0qwv140y2kjfd4spp77zi3v7vnpm4bfy7s7r4cla7xqi49"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-dogged" ,rust-dogged-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-petgraph" ,rust-petgraph-0.4))))
+ (home-page "https://github.com/rust-lang/ena")
+ (synopsis "Union-find, congruence closure, and other unification code")
+ (description "This package provides an implementation of union-find /
+congruence-closure in Rust. It was extracted from rustc for independent
+experimentation.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-encode-unicode-0.3
(package
(name "rust-encode-unicode")