summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-21 01:01:36 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:21 +0200
commit30b610d68c07e903ff3e2f5453d88f31da510a15 (patch)
tree74458e46cc9ae384674fd4dc9e9b96d47374b9ab
parent5b034ab6a65a7f7b7a4758ee9c3593fce246ebae (diff)
downloadpatches-30b610d68c07e903ff3e2f5453d88f31da510a15.tar
patches-30b610d68c07e903ff3e2f5453d88f31da510a15.tar.gz
gnu: Add rust-fallible-streaming-iterator-0.1.
* gnu/packages/crates-io.scm (rust-fallible-streaming-iterator-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cef9ddc765..f9178d710c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6441,6 +6441,23 @@ provides implementations for @code{HashMap} and @code{HashSet}.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-fallible-streaming-iterator-0.1
+ (package
+ (name "rust-fallible-streaming-iterator")
+ (version "0.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fallible-streaming-iterator" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0nj6j26p71bjy8h42x6jahx1hn0ng6mc2miwpgwnp8vnwqf4jq3k"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/sfackler/fallible-streaming-iterator")
+ (synopsis "Fallible streaming iteration")
+ (description "Fallible streaming iteration")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-fern-0.5
(package
(name "rust-fern")