summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-17 09:42:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-17 10:14:02 +0100
commit2d7c4ae3ee83841ef827a160b0d23c1d10d2570d (patch)
tree6d1974e1e975b231c6e78ac00129cf3301e7df85
parentf1fe5283c9f8eb6890b3e6dc3c09a00f4da19472 (diff)
downloadpatches-2d7c4ae3ee83841ef827a160b0d23c1d10d2570d.tar
patches-2d7c4ae3ee83841ef827a160b0d23c1d10d2570d.tar.gz
gnu: r: Rename to r-minimal.
* gnu/packages/statistics.scm (r): Rename to... (r-minimal): ...this new variable. (r-with-recommended-packages): Rename to... (r): ...this. * guix/build-system/r.scm (default-r): Reference r-minimal. * gnu/packages/emacs.scm (emacs-ess)[inputs], gnu/packages/machine-learning.scm (shogun)[inputs], gnu/packages/python.scm (python-rpy2)[inputs], gnu/packages/bioinformatics.scm (ribotaper)[inputs], (couger)[propagated-inputs], (roary)[inputs], (rsem)[inputs], (rcas-web)[inputs]: Change "r" to "r-minimal".
-rw-r--r--gnu/packages/bioinformatics.scm10
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/machine-learning.scm2
-rw-r--r--gnu/packages/python.scm2
-rw-r--r--gnu/packages/statistics.scm12
-rw-r--r--guix/build-system/r.scm2
6 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bd3c97b721..ccde01b119 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -478,7 +478,7 @@ BED, GFF/GTF, VCF.")
(inputs
`(("bedtools" ,bedtools-2.18)
("samtools" ,samtools-0.1)
- ("r" ,r)
+ ("r-minimal" ,r-minimal)
("r-foreach" ,r-foreach)
("r-xnomial" ,r-xnomial)
("r-domc" ,r-domc)
@@ -1728,7 +1728,7 @@ gene predictor designed to work with assembled, aligned RNA-seq transcripts.")
("python2-scipy" ,python2-scipy)
("python2-matplotlib" ,python2-matplotlib)))
(propagated-inputs
- `(("r" ,r)
+ `(("r-minimal" ,r-minimal)
("libsvm" ,libsvm)
("randomjungle" ,randomjungle)))
(native-inputs
@@ -4004,7 +4004,7 @@ partial genes, and identifies translation initiation sites.")
("grep" ,grep)
("sed" ,sed)
("gawk" ,gawk)
- ("r" ,r)
+ ("r-minimal" ,r-minimal)
("r-ggplot2" ,r-ggplot2)
("coreutils" ,coreutils)))
(home-page "http://sanger-pathogens.github.io/Roary")
@@ -4119,7 +4119,7 @@ phylogenies.")
(inputs
`(("boost" ,boost)
("ncurses" ,ncurses)
- ("r" ,r)
+ ("r-minimal" ,r-minimal)
("perl" ,perl)
("samtools" ,samtools-0.1)
("zlib" ,zlib)))
@@ -7636,7 +7636,7 @@ library implementing most of the pipeline's features.")
`("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))))
#t)))))
(inputs
- `(("r" ,r)
+ `(("r-minimal" ,r-minimal)
("r-rcas" ,r-rcas)
("guile-next" ,guile-next)
("guile-json" ,guile2.2-json)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c6e62acb7a..18d25b743b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2924,7 +2924,7 @@ E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
(string-append "SHELL = " (which "sh")))))))))
(inputs
`(("emacs" ,emacs-minimal)
- ("r" ,r)))
+ ("r-minimal" ,r-minimal)))
(native-inputs
`(("perl" ,perl)
("texinfo" ,texinfo)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 73c78744f8..5379893b76 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -402,7 +402,7 @@ sample proximities between pairs of cases.")
(inputs
`(("python" ,python)
("numpy" ,python-numpy)
- ("r" ,r)
+ ("r-minimal" ,r-minimal)
("octave" ,octave)
("swig" ,swig)
("hdf5" ,hdf5)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ba3c7d4c36..6c91401e22 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4085,7 +4085,7 @@ operators such as union, intersection, and difference.")
`(("readline" ,readline)
("icu4c" ,icu4c)
("pcre" ,pcre)
- ("r" ,r)
+ ("r-minimal" ,r-minimal)
("r-survival" ,r-survival)))
(native-inputs
`(("zlib" ,zlib)))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 656895273f..3a26e23053 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -103,9 +103,9 @@ be output in text, PostScript, PDF or HTML.")
;; Update this package together with the set of recommended packages: r-boot,
;; r-class, r-cluster, r-codetools, r-foreign, r-kernsmooth, r-lattice,
;; r-mass, r-matrix, r-mgcv, r-nlme, r-nnet, r-rpart, r-spatial, r-survival.
-(define-public r
+(define-public r-minimal
(package
- (name "r")
+ (name "r-minimal")
(version "3.3.3")
(source (origin
(method url-fetch)
@@ -538,14 +538,14 @@ definition of Surv objects, Kaplan-Meier and Aalen-Johansen (multi-state)
curves, Cox models, and parametric accelerated failure time models.")
(license license:lgpl2.0+)))
-(define-public r-with-recommended-packages
- (package (inherit r)
- (name "r-with-recommended-packages")
+(define-public r
+ (package (inherit r-minimal)
+ (name "r")
(source #f)
(build-system trivial-build-system)
(arguments '(#:builder (mkdir %output)))
(propagated-inputs
- `(("r" ,r)
+ `(("r-minimal" ,r-minimal)
("r-boot" ,r-boot)
("r-class" ,r-class)
("r-cluster" ,r-cluster)
diff --git a/guix/build-system/r.scm b/guix/build-system/r.scm
index e8269fdeb1..c649036210 100644
--- a/guix/build-system/r.scm
+++ b/guix/build-system/r.scm
@@ -62,7 +62,7 @@ release corresponding to NAME and VERSION."
"Return the default R package."
;; Lazily resolve the binding to avoid a circular dependency.
(let ((r-mod (resolve-interface '(gnu packages statistics))))
- (module-ref r-mod 'r)))
+ (module-ref r-mod 'r-minimal)))
(define* (lower name
#:key source inputs native-inputs outputs system target