summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-08 09:55:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:59:02 +0100
commit24f4400aa69925635c229d7f494eabf37e980cae (patch)
treeb260ec2f9b59240588c1aab06027091915fb99e2
parentb51fbd6d6e67cc947c1c2977e08511930e7f7648 (diff)
downloadpatches-24f4400aa69925635c229d7f494eabf37e980cae.tar
patches-24f4400aa69925635c229d7f494eabf37e980cae.tar.gz
gnu: Add python-pyinotify.
* gnu/packages/python.scm (python-pyinotify, python2-pyinotify): New variables.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ee867517fc..a44c3a0fd0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12896,3 +12896,25 @@ interpreter. bpython's main features are
(("^(\\s+'bpython)(-\\S+)?(\\s+=.*',?)\\s*?$" _ name sub rest)
(string-append name "2" (or sub "") rest "\n")))
#t))))))))
+
+(define-public python-pyinotify
+ (package
+ (name "python-pyinotify")
+ (version "0.9.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyinotify" version))
+ (sha256
+ (base32
+ "1x3i9wmzw33fpkis203alygfnrkcmq9w1aydcm887jh6frfqm6cw"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f)) ;no tests
+ (home-page "https://github.com/seb-m/pyinotify")
+ (synopsis "Python library for monitoring inotify events")
+ (description
+ "@code{pyinotify} provides a Python interface for monitoring
+filesystem events on Linux.")
+ (license license:expat)))
+
+(define-public python2-pyinotify
+ (package-with-python2 python-pyinotify))