summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-19 21:46:28 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:22 +0200
commit2380285bd1b98f049c874e5bf6fee023d32dd6ca (patch)
treefb83dbfab39ef0048d6812cda0bb91c1eb15a1f6
parentfea64a43ad36c3ec536d944103f11ead73090bd4 (diff)
downloadpatches-2380285bd1b98f049c874e5bf6fee023d32dd6ca.tar
patches-2380285bd1b98f049c874e5bf6fee023d32dd6ca.tar.gz
gnu: Add rust-http-0.2.
* gnu/packages/crates-io.scm (rust-http-0.2): New variable. (rust-http-0.1): Inherit from it.
-rw-r--r--gnu/packages/crates-io.scm43
1 files changed, 34 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3af7b4d43d..f206977de4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9767,9 +9767,41 @@ compile time.")
"High-performance browser-grade HTML5 parser.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-http-0.1
+(define-public rust-http-0.2
(package
(name "rust-http")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "http" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1y827q7j0gvs8z2x12biaik9db6nb902lpqv889cbcj84sbnkm98"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ;; FIXME requires Rust >= 1.39 for building
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-0.5)
+ ("rust-fnv" ,rust-fnv-1.0)
+ ("rust-itoa" ,rust-itoa-0.4))
+ #:cargo-development-inputs
+ (("rust-doc-comment" ,rust-doc-comment-0.3)
+ ("rust-indexmap" ,rust-indexmap-1.0)
+ ("rust-quickcheck" ,rust-quickcheck-0.9)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-seahash" ,rust-seahash-3.0)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-json" ,rust-serde-json-1.0))))
+ (home-page "https://github.com/hyperium/http")
+ (synopsis "Set of types for representing HTTP requests and responses")
+ (description "This package provides a set of types for representing HTTP
+requests and responses.")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-http-0.1
+ (package/inherit rust-http-0.2
+ (name "rust-http")
(version "0.1.17")
(source
(origin
@@ -9780,7 +9812,6 @@ compile time.")
(sha256
(base32
"06icxvrd26r6s7dzjavja7r47hgjb9851wblqh8frxnsy3q29lzf"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -9793,13 +9824,7 @@ compile time.")
("rust-rand" ,rust-rand-0.4)
("rust-seahash" ,rust-seahash-3.0)
("rust-serde" ,rust-serde-1.0)
- ("rust-serde-json" ,rust-serde-json-1.0))))
- (home-page "https://github.com/hyperium/http")
- (synopsis "Set of types for representing HTTP requests and responses")
- (description
- "This package provides a set of types for representing HTTP
-requests and responses.")
- (license (list license:asl2.0 license:expat))))
+ ("rust-serde-json" ,rust-serde-json-1.0))))))
(define-public rust-http-req-0.5
(package