summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-20 22:25:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:24 +0200
commit1a02238711e4b5f8ba73ee24b59355049fd569bb (patch)
treea53c4426d26ceaab0c3a1b9954c7a2b56e685715
parentc199ef65039c6225e51d56f717068c0a62c7a6c1 (diff)
downloadpatches-1a02238711e4b5f8ba73ee24b59355049fd569bb.tar
patches-1a02238711e4b5f8ba73ee24b59355049fd569bb.tar.gz
gnu: Add rust-hyper-tls-0.3.
* gnu/packages/crates-io.scm (rust-hyper-tls-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 11bd0925d1..72af7e3e90 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10017,6 +10017,36 @@ SystemTime}}.")
(description "This package provides a fast and correct HTTP library.")
(license license:expat)) )
+(define-public rust-hyper-tls-0.3
+ (package
+ (name "rust-hyper-tls")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hyper-tls" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0kqp4sz8613j6nv375wfj3gh95ff4nb6a3rb1f2vbx0almm0v01s"))))
+ (build-system cargo-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bytes" ,rust-bytes-0.4)
+ ("rust-futures" ,rust-futures-0.1)
+ ("rust-hyper" ,rust-hyper-0.12)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-tokio-io" ,rust-tokio-io-0.1))
+ #:cargo-development-inputs
+ (("rust-tokio" ,rust-tokio-0.1))))
+ (home-page "https://hyper.rs")
+ (synopsis "Default TLS implementation for use with hyper")
+ (description "Default TLS implementation for use with hyper")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-idna-0.2
(package
(name "rust-idna")