summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-08 14:00:37 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:32 +0200
commit199816190978616d6f101987aa64a5b1bb421c62 (patch)
treed9831720cf000d7d0b398031d0eab5583c40f382
parentff8abd44cdd189c4093907d03854cbb69470ea82 (diff)
downloadpatches-199816190978616d6f101987aa64a5b1bb421c62.tar
patches-199816190978616d6f101987aa64a5b1bb421c62.tar.gz
gnu: Add rust-rspec-1.
* gnu/packages/crates-io.scm (rust-rspec-1.0): New variable.
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4dedff2d1f..7292ab7449 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18860,6 +18860,34 @@ uses finite automata and guarantees linear time matching on all inputs.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-rspec-1
+ (package
+ (name "rust-rspec")
+ (version "1.0.0-beta.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rspec" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1abfzwkbxlwahb243k8d3fp6i135lx1aqmbfl79w9zlpng182ndk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ;; TODO unpackaged dev-dependencies
+ #:cargo-inputs
+ (("rust-colored" ,rust-colored-1.9)
+ ("rust-derive-new" ,rust-derive-new-0.5)
+ ("rust-derive-builder" ,rust-derive-builder-0.5)
+ ("rust-expectest" ,rust-expectest-0.9)
+ ("rust-rayon" ,rust-rayon-0.8))
+ #:cargo-development-inputs
+ (("rust-clippy" ,rust-clippy-0.0)))) ;; requires 0.0.153
+ (home-page "https://github.com/rust-rspec/rspec")
+ (synopsis "Write Rspec-like tests with stable rust")
+ (description "This package helps writing Rspec-like tests with stable
+rust.")
+ (license license:mpl2.0)))
+
(define-public rust-rpassword-4
(package
(name "rust-rpassword")