summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-25 13:25:05 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:44 +0200
commit1431405e3fd5fdb31d01245d4e43815c90914021 (patch)
tree526c8d992fcd21d2295c7bb0ee27354e1cff052c
parent5b4051bf0bba1623f81381fccd680f509c5482ed (diff)
downloadpatches-1431405e3fd5fdb31d01245d4e43815c90914021.tar
patches-1431405e3fd5fdb31d01245d4e43815c90914021.tar.gz
gnu: Add rust-webpki-roots-0.14.
* gnu/packages/crates-io.scm (rust-webpki-roots-0.14): New variable.
-rw-r--r--gnu/packages/crates-io.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index df7e6a8a89..e34135cab9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26718,6 +26718,22 @@ Verification.")
(sha256
(base32 "12vi8dh0yik0h4f0b9dnlw5i3gxyky7iblbksh6zcq4xvlvswqm2"))))))
+(define-public rust-webpki-roots-0.14
+ (package/inherit rust-webpki-roots-0.18
+ (name "rust-webpki-roots")
+ (version "0.14.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "webpki-roots" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "05zw919077i3jadbvdsvl69wv2siijg2pjbykl6fyi7hmgb7bggd"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-untrusted" ,rust-untrusted-0.6)
+ ("rust-webpki" ,rust-webpki-0.18))))))
+
(define-public rust-weedle-0.10
(package
(name "rust-weedle")