summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2016-03-27 19:28:37 -0700
committerLudovic Courtès <ludo@gnu.org>2016-03-30 23:39:47 +0200
commit12af303f4736b19679142047327e55898e18eb9d (patch)
treea99c1063dbb1163ee20c1010eb1c9346596691b6
parentdaeeea715473b5c698647f8fcc5729ac62ac8191 (diff)
downloadpatches-12af303f4736b19679142047327e55898e18eb9d.tar
patches-12af303f4736b19679142047327e55898e18eb9d.tar.gz
gnu: Add python2-s3cmd.
* gnu/packages/python.scm (python2-s3cmd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b1d640456d..e32022606e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8554,3 +8554,42 @@ the same purpose: to provide Python bindings for libmagic.")
(define-public python2-magic
(package-with-python2 python-magic))
+
+(define-public python2-s3cmd
+ (package
+ (name "python2-s3cmd")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/s3tools/"
+ "s3cmd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ki1rzhm5icvi9ry5jswi4b22yqwyj0d2wsqsgilwx6qhi7pjxa6"))))
+ (build-system python-build-system)
+ (arguments
+ ;; s3cmd is written for python2 only and contains no tests.
+ `(#:python ,python-2
+ #:tests? #f))
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)))
+ (inputs
+ `(("python2-dateutil" ,python2-dateutil)
+ ;; The python-file package also provides a magic.py module.
+ ;; This is an unfortunate state of affairs; however, s3cmd
+ ;; fails to install if it cannot find specifically the
+ ;; python-magic package. Thus we include it, instead of using
+ ;; python-file. Ironically, s3cmd sometimes works better
+ ;; without libmagic bindings at all:
+ ;; https://github.com/s3tools/s3cmd/issues/198
+ ("python2-magic" ,python2-magic)))
+ (home-page "http://s3tools.org/s3cmd")
+ (synopsis "Command line tool for S3-compatible storage services")
+ (description
+ "S3cmd is a command line tool for uploading, retrieving and managing data
+in storage services that are compatible with the Amazon Simple Storage
+Service (S3) protocol, including S3 itself. It supports rsync-like backup,
+GnuPG encryption, and more. It also supports management of Amazon's
+CloudFront content delivery network.")
+ (license gpl2+)))