summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-19 22:35:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:42 +0200
commit0e52427150044afecefd9f4534d491a6b569e5e2 (patch)
treee9b9981ef5fe339434438715ac2cc3f00a2dbad5
parent5415f9d2a0cbd8b892ce4560b5bd47d23b4d6dbc (diff)
downloadpatches-0e52427150044afecefd9f4534d491a6b569e5e2.tar
patches-0e52427150044afecefd9f4534d491a6b569e5e2.tar.gz
gnu: Add rust-webpki-0.21.
* gnu/packages/crates-io.scm (rust-webpki-0.21): New variable.
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fad514644e..ccda9bf203 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26643,6 +26643,31 @@ protocol extensions. Look at the crate wayland-client for usable bindings.")
"Bindings for all Web APIs, a procedurally generated crate from WebIDL.")
(license (list license:expat license:asl2.0))))
+(define-public rust-webpki-0.21
+ (package
+ (name "rust-webpki")
+ (version "0.21.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "webpki" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1vv3x2alvczfy6jhx79c9h00d1nliqf7s5jlvcd6npc6f8chxxgi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ;; tests fail to build "missing file tests/ed25519/ee.der"
+ #:cargo-inputs
+ (("rust-ring" ,rust-ring-0.16)
+ ("rust-untrusted" ,rust-untrusted-0.7))
+ #:cargo-development-inputs
+ (("rust-base64" ,rust-base64-0.9))))
+ (home-page "https://github.com/briansmith/webpki")
+ (synopsis "Web PKI X.509 Certificate Verification")
+ (description "This packge provides Web PKI X.509 Certificate
+Verification.")
+ (license license:isc)))
+
(define-public rust-weedle-0.10
(package
(name "rust-weedle")