summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-05-03 22:40:57 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-03 23:04:58 +0200
commitda09c63e78ebebeabb347f483d7284b87ff51c2f (patch)
tree218c51f33aed1f40b17e6bee1fb4208bf52eba1f
parentbb357c509e1c017e1fef5aa5f4d05beea0c25157 (diff)
downloadpatches-da09c63e78ebebeabb347f483d7284b87ff51c2f.tar
patches-da09c63e78ebebeabb347f483d7284b87ff51c2f.tar.gz
gnu: f2fs-tools-static: Work around bug in our util-linux.
* gnu/packages/linux.scm (f2fs-tools/static): Work around bug in our util-linux.
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f7c42ffba7..3de29a59ed 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4628,7 +4628,14 @@ disks and SD cards. This package provides the userland utilities.")
(append-to-file "mkfs/Makefile.am" "\nmkfs_f2fs_LDFLAGS = -all-static\n")
(append-to-file "fsck/Makefile.am" "\nfsck_f2fs_LDFLAGS = -all-static\n")
(append-to-file "tools/Makefile.am" "\nf2fscrypt_LDFLAGS = -all-static -luuid\n")
- #t)))))
+ #t))
+ (add-after 'install 'remove-store-references
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Work around bug in our util-linux.
+ ;; <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=41019>.
+ (remove-store-references (string-append (assoc-ref outputs "out")
+ "/sbin/mkfs.f2fs"))
+ #t)))))
(inputs
`(("libuuid:static" ,util-linux "static")
("libuuid" ,util-linux)))))) ; for include files