summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-08 18:43:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:27:24 +0100
commitd16ef28b8037664ad08af5fb825811e9f46bb64c (patch)
treeab7b62f8c52a0d9bfb336a3b86cd1126e20ecbf6
parentac63cf0a6995fb9de6121e648b401167895b2c9d (diff)
downloadpatches-d16ef28b8037664ad08af5fb825811e9f46bb64c.tar
patches-d16ef28b8037664ad08af5fb825811e9f46bb64c.tar.gz
gnu: python-pycodestyle: Update to 2.5.0.
* gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-xyz.scm (python-pycodestyle): Update to 2.5.0. [source](patches): Remove.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch35
-rw-r--r--gnu/packages/python-xyz.scm5
3 files changed, 2 insertions, 39 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 41f81d0d0b..9df65b9d21 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1171,7 +1171,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \
%D%/packages/patches/python-paste-remove-timing-test.patch \
- %D%/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch \
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
diff --git a/gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch b/gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch
deleted file mode 100644
index 16388c8dba..0000000000
--- a/gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 397463014fda3cdefe8d6c9d117ae16d878dc494 Mon Sep 17 00:00:00 2001
-From: Michael Hudson-Doyle <michael.hudson@canonical.com>
-Date: Tue, 25 Sep 2018 14:58:57 +1200
-Subject: [PATCH] Keep compability with stdlib tokenize.py changes
-
-https://github.com/python/cpython/commit/c4ef4896eac86a6759901c8546e26de4695a1389
-is not yet part of any release of Python but has been backported to all
-versions in Git (includeing 2.7!). It causes the tokenize.py module to
-emit a synthetic NEWLINE token for files that do not in fact end with a
-newline, which confuses pycodestyle's checks for blank lines at the end
-of a file. Fortunately the synthetic NEWLINE tokens are easy to detect
-(the token text is "").
-
-Fixes #786
----
- pycodestyle.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/pycodestyle.py b/pycodestyle.py
-index 0d725d27..fbc3dca3 100755
---- a/pycodestyle.py
-+++ b/pycodestyle.py
-@@ -258,10 +258,10 @@ def trailing_blank_lines(physical_line, lines, line_number, total_lines):
- """
- if line_number == total_lines:
- stripped_last_line = physical_line.rstrip()
-- if not stripped_last_line:
-+ if physical_line and not stripped_last_line:
- return 0, "W391 blank line at end of file"
- if stripped_last_line == physical_line:
-- return len(physical_line), "W292 no newline at end of file"
-+ return len(lines[-1]), "W292 no newline at end of file"
-
-
- @register_check
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b92bed542f..9d80531296 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3593,15 +3593,14 @@ as the original project seems to have been abandoned circa 2007.")
(define-public python-pycodestyle
(package
(name "python-pycodestyle")
- (version "2.4.0")
+ (version "2.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pycodestyle" version))
(sha256
(base32
- "0fhy4vnlgpjq4qd1wdnl6pvdw7rah0ypmn8c9mkhz8clsndskz6b"))
- (patches (search-patches "python-pycodestyle-stdlib-tokenize-fix.patch"))))
+ "0v4prb05n21bm8650v0a01k1nyqjdmkrsm3zycfxh2j5k9n962p4"))))
(build-system python-build-system)
(home-page "https://pycodestyle.readthedocs.io/")
(synopsis "Python style guide checker")