summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-08 17:45:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:27:24 +0100
commitac63cf0a6995fb9de6121e648b401167895b2c9d (patch)
tree9723d68c3bc9d249d1e30760f8718884ee619418
parent5b972c3256eff3588ad516b6ae64f2b948cac7c5 (diff)
downloadpatches-ac63cf0a6995fb9de6121e648b401167895b2c9d.tar
patches-ac63cf0a6995fb9de6121e648b401167895b2c9d.tar.gz
gnu: Remove python-flake8@3.5.
* gnu/packages/python-xyz.scm (python-flake8-3.5): Rename to ... (python-flake8): ... this. Update to 3.6.0. Remove previous variant. [arguments]: Remove phases 'delete-broken-test' and 'fix-problem-with-pycodestyle'. [properties]: Adjust for renamed variable. (python2-flake8-3.5): Rename to ... (python2-flake8): ... this. Remove previous variable. * gnu/packages/check.scm (python-hypothesis)[native-inputs]: Adjust accordingly.
-rw-r--r--gnu/packages/check.scm3
-rw-r--r--gnu/packages/python-xyz.scm65
2 files changed, 12 insertions, 56 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index afb3b96aba..02ee9b136b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1456,8 +1456,7 @@ instantly.")
"0fvq4mfybm129l978war86mcshkn28dkrxw7lr8549zr9ywvik1c"))))
(build-system python-build-system)
(native-inputs
- `(;; FIXME: Change to python-flake8 in the next rebuild cycle.
- ("python-flake8" ,python-flake8-3.5)
+ `(("python-flake8" ,python-flake8)
("python-pytest" ,python-pytest-bootstrap)))
(propagated-inputs
`(("python-attrs" ,python-attrs-bootstrap)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 38241c67f8..b92bed542f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5556,35 +5556,20 @@ complexity of Python source code.")
(define-public python2-pyflakes-0.8.1
(package-with-python2 python-pyflakes-0.8.1))
-;; This package is used by hypothesis which has thousands of dependent packages.
-;; FIXME: Consolidate this with "python-flake8" below in the next rebuild cycle.
-(define-public python-flake8-3.5
+(define-public python-flake8
(package
(name "python-flake8")
- (version "3.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "184b33grvvjmiwlv9kyd7yng9qv5ld24154j70z332xxg9gjclvj"))))
+ (version "3.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8" version))
+ (sha256
+ (base32
+ "0w0nprx22rbvrrkbfx9v5jc5gskbm08g219l7r8wai8zfswgadba"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Two errors don't seem to have assigned codes.
- (add-after 'unpack 'delete-broken-test
- (lambda _ (delete-file "tests/unit/test_pyflakes_codes.py") #t))
- (add-after 'unpack 'fix-problem-with-pycodestyle
- (lambda _
- ;; See https://gitlab.com/pycqa/flake8/merge_requests/230
- ;; This should no longer be needed with the next release.
- (substitute* "setup.py"
- (("PEP8_PLUGIN\\('break_around_binary_operator'\\),")
- "PEP8_PLUGIN('break_after_binary_operator'),\
-PEP8_PLUGIN('break_before_binary_operator'),"))
- #t))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -5604,45 +5589,17 @@ PEP8_PLUGIN('break_before_binary_operator'),"))
"The modular source code checker: pep8, pyflakes and co")
(description
"Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
- (properties `((python2-variant . ,(delay python2-flake8-3.5))))
+ (properties `((python2-variant . ,(delay python2-flake8))))
(license license:expat)))
-(define-public python2-flake8-3.5
- (let ((base (package-with-python2 (strip-python2-variant python-flake8-3.5))))
+(define-public python2-flake8
+ (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
(package (inherit base)
(propagated-inputs
`(("python2-configparser" ,python2-configparser)
("python2-enum34" ,python2-enum34)
,@(package-propagated-inputs base))))))
-;; Version 3.5.0 has compatibility issues with Pyflakes 2.0, so we need
-;; this newer version. Keep it as a separate variable for now to avoid
-;; rebuilding "python-hypothesis"; this should be removed in the next
-;; rebuild cycle.
-(define-public python-flake8
- (package
- (inherit python-flake8-3.5)
- (version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "0w0nprx22rbvrrkbfx9v5jc5gskbm08g219l7r8wai8zfswgadba"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-flake8-3.5)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'delete-broken-test)
- (delete 'fix-problem-with-pycodestyle)))))
- (properties `((python2-variant . ,(delay python2-flake8))))))
-
-(define-public python2-flake8
- (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
- (package (inherit base)
- (propagated-inputs
- (package-propagated-inputs python2-flake8-3.5)))))
-
;; python-hacking requires flake8 <2.6.0.
(define-public python-flake8-2.5
(package