summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorraingloom <raingloom@protonmail.com>2020-04-03 04:18:26 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-03 12:06:58 +0200
commita5cf52d3aa31717a8ae0c2cbbc4b848266ed7818 (patch)
tree053c674d5325208e0224c787d606df761d1209cf
parent17adb70f78b34a490b8e692f1a110cef72097685 (diff)
downloadpatches-a5cf52d3aa31717a8ae0c2cbbc4b848266ed7818.tar
patches-a5cf52d3aa31717a8ae0c2cbbc4b848266ed7818.tar.gz
gnu: Add f2fs-fsck-static.
* gnu/packages/linux.scm (f2fs-fsck/static): New public variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index df442920de..f7c42ffba7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4633,6 +4633,38 @@ disks and SD cards. This package provides the userland utilities.")
`(("libuuid:static" ,util-linux "static")
("libuuid" ,util-linux)))))) ; for include files
+(define-public f2fs-fsck/static
+ (package
+ (name "f2fs-fsck-static")
+ (version (package-version f2fs-tools/static))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-26))
+ (let* ((f2fs-tools (assoc-ref %build-inputs "f2fs-tools-static"))
+ (fsck "fsck.f2fs")
+ (out (assoc-ref %outputs "out"))
+ (sbin (string-append out "/sbin")))
+ (mkdir-p sbin)
+ (with-directory-excursion sbin
+ (install-file (string-append f2fs-tools "/sbin/" fsck)
+ ".")
+ (remove-store-references fsck)
+ (chmod fsck #o555))
+ #t))))
+ (inputs
+ `(("f2fs-tools-static" ,f2fs-tools/static)))
+ (home-page (package-home-page f2fs-tools/static))
+ (synopsis "Statically-linked fsck.f2fs command from f2fs-tools")
+ (description "This package provides statically-linked fsck.f2fs command taken
+from the f2fs-tools package. It is meant to be used in initrds.")
+ (license (package-license f2fs-tools/static))))
+
(define-public freefall
(package
(name "freefall")