summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-07-05 16:13:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-05 16:32:37 +0200
commit5fb5dffbd432e1b4dd645a5bedf40e1404fffc34 (patch)
treecbf06604c55649ca76a18e7e4d88095e83b99a51
parent091963c69b517a97aaf2cad62e700ecb6c855a93 (diff)
downloadpatches-5fb5dffbd432e1b4dd645a5bedf40e1404fffc34.tar
patches-5fb5dffbd432e1b4dd645a5bedf40e1404fffc34.tar.gz
gnu: Add multiqc.
* gnu/packages/bioinformatics.scm (multiqc): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 35bed0f76e..4cd90b9e81 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5720,3 +5720,32 @@ group or two ChIP groups run under different conditions.")
(description "This program compares version strings. It intends to be a
replacement for strverscmp.")
(license license:gpl3+))))
+
+(define-public multiqc
+ (package
+ (name "multiqc")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "multiqc" version))
+ (sha256
+ (base32
+ "0avw11h63ldpxy5pizc3wl1wa01ha7q10wb240nggsjz3jaqvyiy"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-jinja2" ,python-jinja2)
+ ("python-simplejson" ,python-simplejson)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-click" ,python-click)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://multiqc.info")
+ (synopsis "Aggregate bioinformatics analysis reports")
+ (description
+ "MultiQC is a tool to aggregate bioinformatics results across many
+samples into a single report. It contains modules for a large number of
+common bioinformatics tools.")
+ (license license:gpl3)))