summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-05-04 00:32:38 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-04 10:25:33 +0200
commit1c5604017bcbab9bad6bf287ff89da0d9f35f93f (patch)
tree6d54df6e99e35668d0a19228d31374dc173180b8
parent4a84deda7489f668cd833b59daeb504cbd87fa2b (diff)
downloadpatches-1c5604017bcbab9bad6bf287ff89da0d9f35f93f.tar
patches-1c5604017bcbab9bad6bf287ff89da0d9f35f93f.tar.gz
gnu: Add tng.
* gnu/packages/chemistry.scm (tng): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/chemistry.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 855ae2df22..5b21e3309c 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -300,6 +301,41 @@ is currently not actively maintained and works only with Python 2 and
NumPy < 1.9.")
(license license:cecill)))
+(define-public tng
+ (package
+ (name "tng")
+ (version "1.8.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gromacs/tng.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1apf2n8nb34z09xarj7k4jgriq283l769sakjmj5aalpbilvai4q"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-bundled-zlib
+ (lambda _
+ (delete-file-recursively "external")
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "../build/bin/tests/tng_testing")
+ #t)))))
+ (home-page "https://github.com/gromacs/tng")
+ (synopsis "Trajectory Next Generation binary format manipulation library")
+ (description "TRAJNG (Trajectory next generation) is a program library for
+handling molecular dynamics (MD) trajectories. It can store coordinates, and
+optionally velocities and the H-matrix. Coordinates and velocities are
+stored with user-specified precision.")
+ (license license:bsd-3)))
+
(define-public openbabel
(package
(name "openbabel")