summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-12 20:27:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit1c32830b7d3496c2729449ef0d0f9f72d543b308 (patch)
tree3e2b06fb7080196be11b957870793fd6617b5c67
parenta2285798832daa6b4d33aac3382171ec25ea032d (diff)
downloadpatches-1c32830b7d3496c2729449ef0d0f9f72d543b308.tar
patches-1c32830b7d3496c2729449ef0d0f9f72d543b308.tar.gz
gnu: Add emacs-el-mock.
* gnu/packages/emacs.scm (emacs-el-mock): New variable.
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3e6a2b5df4..95c8d9b756 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1283,6 +1283,28 @@ strings.")
files and directories.")
(license license:gpl3+)))
+(define-public emacs-el-mock
+ (package
+ (name "emacs-el-mock")
+ (version "1.25.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rejeep/el-mock.el/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16xw94n58xxn3zvgyj72bmzs0k5lkvswjmzs79ws9n7rzdivb38b"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/rejeep/el-mock.el")
+ (synopsis "Tiny mock and stub framework in Emacs Lisp")
+ (description
+ "Emacs Lisp Mock is a library for mocking and stubbing using readable
+syntax. Most commonly Emacs Lisp Mock is used in conjunction with Emacs Lisp
+Expectations, but it can be used in other contexts.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")