summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-08 18:50:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:27:25 +0100
commit16e03a521e3d4a0b0415cacb87d66d88a5463f67 (patch)
tree0508b49e52aebfe70f91c1f71d39c0587e06de40
parent84127f8c300b6485d1fc476ccb2a0bf06cea683e (diff)
downloadpatches-16e03a521e3d4a0b0415cacb87d66d88a5463f67.tar
patches-16e03a521e3d4a0b0415cacb87d66d88a5463f67.tar.gz
gnu: python-more-itertools: Update to 5.0.0.
* gnu/packages/python-xyz.scm (python-more-itertools): Update to 5.0.0. [arguments]: Remove.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 89a1ec0172..3c9da320cc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13560,29 +13560,15 @@ file system events on Linux.")
(define-public python-more-itertools
(package
(name "python-more-itertools")
- (version "4.3.0")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "more-itertools" version))
(sha256
(base32
- "17h3na0rdh8xq30w4b9pizgkdxmm51896bxw600x84jflg9vaxn4"))))
+ "1r12cm6mcdwdzz7d47a6g4l437xsvapdlgyhqay3i2nrlv03da9q"))))
(build-system python-build-system)
- (arguments
- `(,@(if (any (cute string-prefix? <> (or (%current-system)
- (%current-target-system)))
- '("armhf" "i686"))
- '(#:phases
- (modify-phases %standard-phases
- ;; This is required for 32-bit hardware.
- ;; TODO: Try to remove this when upgrading.
- (add-after 'unpack 'patch-test
- (lambda _
- (substitute* "more_itertools/tests/test_more.py"
- (("10 \\*\\* 10") "9 ** 9"))
- #t))))
- '())))
(propagated-inputs
`(("python-six" ,python-six-bootstrap)))
(home-page "https://github.com/erikrose/more-itertools")