summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-07-03 14:34:34 -0400
committerKei Kebreau <kei@openmailbox.org>2017-07-10 19:35:44 -0400
commit082725b5027a3782f242b634f94b9049d4c7f309 (patch)
tree7593e8bd9d4d6bcf795954624c02255269fddb26
parent5e3ea571c5ac10858b2a1d6d3dc94a26408ae601 (diff)
downloadpatches-082725b5027a3782f242b634f94b9049d4c7f309.tar
patches-082725b5027a3782f242b634f94b9049d4c7f309.tar.gz
gnu: hop: Update to 3.1.0-pre2.
* gnu/packages/scheme.scm (hop): Update to 3.1.0-pre2. [source]: Remove unnecessary patch. [arguments]: Enable tests; disable parallel building; specify BIGLOO in make-flags. [inputs]: Add libgc, libunistring, libuv, pcre and sqlite. * gnu/local.mk (dist_patch_DATA): Remove unnecessary patch. * gnu/packages/patches/hop-linker-flags.patch: Delete file.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/hop-linker-flags.patch60
-rw-r--r--gnu/packages/scheme.scm23
3 files changed, 15 insertions, 69 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f73a6ddd08..199792b4f3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -688,7 +688,6 @@ dist_patch_DATA = \
%D%/packages/patches/hdf-eos5-fix-szip.patch \
%D%/packages/patches/hdf-eos5-fortrantests.patch \
%D%/packages/patches/higan-remove-march-native-flag.patch \
- %D%/packages/patches/hop-linker-flags.patch \
%D%/packages/patches/hubbub-sort-entities.patch \
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \
%D%/packages/patches/hydra-disable-darcs-test.patch \
diff --git a/gnu/packages/patches/hop-linker-flags.patch b/gnu/packages/patches/hop-linker-flags.patch
deleted file mode 100644
index f1f5dbfbd9..0000000000
--- a/gnu/packages/patches/hop-linker-flags.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Make hop's link rules honor flags set by the --blflags configure argument.
-
---- hop-2.4.0/src/Makefile 2015-05-05 19:41:04.800151036 -0500
-+++ hop-2.4.0/src/Makefile 2015-05-05 19:40:40.916150417 -0500
-@@ -69,10 +69,10 @@
- $(MAKE) link.$(LINK) DEST=$@
-
- link.dynamic:
-- @ $(call link,$(BIGLOO),$(BCFLAGS),$(BCFLAGSDEV),$(OBJECTS),-o,$(DEST))
-+ @ $(call link,$(BIGLOO),$(BCFLAGS) $(BLFLAGS),$(BCFLAGSDEV),$(OBJECTS),-o,$(DEST))
-
- link.static:
-- @ $(call link,$(BIGLOO),$(BCFLAGS),$(BCFLAGSDEV),-static-all-bigloo $(OBJECTS),-o,$(DEST))
-+ @ $(call link,$(BIGLOO),$(BCFLAGS) $(BLFLAGS),$(BCFLAGSDEV),-static-all-bigloo $(OBJECTS),-o,$(DEST))
-
- link.library:
- echo "***ERROR: link.library not currently supported!"
---- hop-2.4.0/hopc/Makefile 2013-01-30 07:17:59.000000000 -0600
-+++ hop-2.4.0/hopc/Makefile 2015-05-05 19:45:21.876157699 -0500
-@@ -62,7 +62,7 @@
- mkdir -p $@
-
- $(BUILDBINDIR)/$(EXEC): .afile .etags $(OBJECTS)
-- @ $(call link,$(BIGLOO),$(BCFLAGS),,$(OBJECTS),-o,$@)
-+ @ $(call link,$(BIGLOO),$(BCFLAGS) $(BLFLAGS),$(BCFLAGSDEV),$(OBJECTS),-o,$@)
-
- $(BUILDBINDIR)/$(EXEC).jar: .afile .etags .jfile $(BGL_CLASSES) META-INF/MANIFEST.MF jvm-stdlibs jvm-share jvm-lib
- $(JAR) $@ META-INF/MANIFEST.MF -C o/class_s .
---- hop-2.4.0/hophz/Makefile 2013-01-30 07:17:59.000000000 -0600
-+++ hop-2.4.0/hophz/Makefile 2015-05-05 19:59:42.996180030 -0500
-@@ -16,9 +16,6 @@
- -include ../etc/Makefile.hopconfig
- -include ../etc/Makefile.version
-
--BLFLAGS =
--BLINKFLAGS = -suffix hop
--
- #*---------------------------------------------------------------------*/
- #* Target and Project */
- #*---------------------------------------------------------------------*/
-@@ -72,7 +69,7 @@
- mkdir -p $@
-
- $(BUILDBINDIR)/$(EXEC): .afile .etags $(OBJECTS)
-- @ $(call link,$(BIGLOO),$(BCFLAGS),$(BLINKFLAGS),$(OBJECTS),-o,$@)
-+ @ $(call link,$(BIGLOO),$(BCFLAGS) $(BLFLAGS),$(BCFLAGSDEV),$(OBJECTS),-o,$@)
-
- $(BUILDBINDIR)/$(EXEC).jar: .afile .etags .jfile $(BGL_CLASSES) META-INF/MANIFEST.MF jvm-stdlibs jvm-share jvm-lib
- @ $(JAR) $@ META-INF/MANIFEST.MF -C o/class_s .
---- hop-2.4.0/hopsh/Makefile 2013-01-30 07:17:59.000000000 -0600
-+++ hop-2.4.0/hopsh/Makefile 2015-05-05 19:46:36.060159626 -0500
-@@ -60,7 +60,7 @@
- mkdir -p $@
-
- $(BUILDBINDIR)/$(EXEC): .afile .etags $(OBJECTS)
-- @ $(call link,$(BIGLOO),$(BCFLAGS),$(BCFLAGSDEV),$(OBJECTS),-o,$@)
-+ @ $(call link,$(BIGLOO),$(BCFLAGS) $(BLFLAGS),$(BCFLAGSDEV),$(OBJECTS),-o,$@)
-
- $(BUILDBINDIR)/$(EXEC).jar: .afile .etags .jfile $(BGL_CLASSES) META-INF/MANIFEST.MF jvm-stdlibs jvm-share jvm-lib
- @ $(JAR) $@ META-INF/MANIFEST.MF -C o/class_s .
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 8c8922d89f..92c0170205 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -288,21 +288,23 @@ Scheme and C programs and between Scheme and Java programs.")
(define-public hop
(package
(name "hop")
- (version "2.5.1")
+ (version "3.1.0-pre2")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Hop/hop-"
version ".tar.gz"))
(sha256
(base32
- "1bvp7pc71bln5yvfj87s8750c6l53wjl6f8m12v62q9926adhwys"))
- (patches (search-patches "hop-linker-flags.patch"))))
+ "09m7pahjsp7wxzd20cdph9j3mgf2nq5dyckcjljcd40m25v85kks"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:test-target "test"
+ #:make-flags '("BIGLOO=bigloo")
+ #:parallel-build? #f
+ #:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(zero?
(system* "./configure"
@@ -310,11 +312,16 @@ Scheme and C programs and between Scheme and Java programs.")
(string-append "--blflags="
;; user flags completely override useful
;; default flags, so repeat them here.
- "-copt \\$(CPICFLAGS) -L\\$(BUILDLIBDIR) "
- "-ldopt -Wl,-rpath," out "/lib")))))))
- #:tests? #f)) ; no test suite
+ "-copt \\$(CPICFLAGS) "
+ "-L \\$(BUILDLIBDIR) "
+ "-ldopt -Wl,-rpath," out "/lib")))))))))
(inputs `(("avahi" ,avahi)
("bigloo" ,bigloo)
+ ("libgc" ,libgc)
+ ("libunistring" ,libunistring)
+ ("libuv" ,libuv)
+ ("pcre" ,pcre)
+ ("sqlite" ,sqlite)
("which" ,which)))
(home-page "http://hop.inria.fr/")
(synopsis "Multi-tier programming language for the Web 2.0")