summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-04-20 23:56:15 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-02 16:49:29 +0200
commitfc570fab8039f5090997b082930db812846be5bf (patch)
treebc2714f5428cbc3777481017513f1773612d99d5
parent7bb0ba81b394d82f56ee9d238919c7112e4666fd (diff)
downloadpatches-fc570fab8039f5090997b082930db812846be5bf.tar
patches-fc570fab8039f5090997b082930db812846be5bf.tar.gz
gnu: portmidi-for-extempore: Update to 217-0.8602f54.
* gnu/packages/music.scm (portmidi-for-extempore): Update to 217-0.8602f54. [version]: Use git-version to include latest changes. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/music.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7e8f5e581e..5227f450aa 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1979,24 +1979,27 @@ using a system-independent interface.")
(license license:expat)))
(define-public portmidi-for-extempore
- (package (inherit portmidi)
- (name "portmidi-for-extempore")
- (version "217")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/extemporelang/portmidi.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1inriyrjf7xx2b7r54x0vmf9ngyqgr7g5060c22bwkbsgg53apzv"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; no tests
- (native-inputs '())
- ;; Extempore refuses to build on architectures other than x86_64
- (supported-systems '("x86_64-linux"))
- (home-page "https://github.com/extemporelang/portmidi/")))
+ (let ((version "217")
+ (revision "0")
+ (commit "8602f548f71daf5ef638b2f7d224753400cb2158"))
+ (package (inherit portmidi)
+ (name "portmidi-for-extempore")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/extemporelang/portmidi.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qidzl1s3kzhczzm96rcd2ppn27a97k2axgfh1zhvyf0s52d7m4w"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests
+ (native-inputs '())
+ ;; Extempore refuses to build on architectures other than x86_64
+ (supported-systems '("x86_64-linux"))
+ (home-page "https://github.com/extemporelang/portmidi/"))))
(define-public python-pyportmidi
(package