summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-25 21:42:38 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-26 22:47:16 +0300
commite5e5eb1fcf4c0aab10e2d6ed7fa34257a3c87e58 (patch)
treeba717d4ef61e4a6c92e45e6955eccff85cd80d2c
parente0de023eae9f98cb809a4866a84d85efaa262e56 (diff)
downloadpatches-e5e5eb1fcf4c0aab10e2d6ed7fa34257a3c87e58.tar
patches-e5e5eb1fcf4c0aab10e2d6ed7fa34257a3c87e58.tar.gz
gnu: Add twitchy.
* gnu/packages/video.scm (twitchy): New public variable.
-rw-r--r--gnu/packages/video.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6b214d49ad..3937c52c01 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1783,6 +1783,38 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(define-public livestreamer
(deprecated-package "livestreamer" streamlink))
+(define-public twitchy
+ (let ((commit "0c0f925b9c7ff2aed4a3b0046561cb794143c398")) ;Fixes tests.
+ (package
+ (name "twitchy")
+ (version (git-version "3.2" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BasioMeusPuga/twitchy.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02aizvsr744sh8bdqvwwsmp2qpczlzn8fy76h5dyd3517n9nlcz9"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "HOME" (getcwd)) ;Needs to write to ‘$HOME’.
+ #t)))))
+ (inputs
+ `(("python-requests" ,python-requests)
+ ("streamlink" ,streamlink)))
+ (home-page "https://github.com/BasioMeusPuga/twitchy")
+ (synopsis "Command-line interface for Twitch.tv")
+ (description
+ "This package provides a command-line interface for Twitch.tv")
+ (license license:gpl3+))))
+
(define-public mlt
(package
(name "mlt")