summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-03 09:23:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-03 09:34:46 +0300
commitb34793c14372fbda2246d68ef6270f1207e53e98 (patch)
treec78f413c832610e8fd49fd4d8a4881e14f5fbd58
parent8a0b02c248a9877812cce29641bb1843cb77ea19 (diff)
downloadpatches-b34793c14372fbda2246d68ef6270f1207e53e98.tar
patches-b34793c14372fbda2246d68ef6270f1207e53e98.tar.gz
gnu: efl: Update to 1.24.0.
* gnu/packages/enlightenment.scm (efl): Update to 1.24.0. [propagated-inputs]: Remove bullet. Add libpng. Move libtiff, libwebp ... [inputs]: ... to here. Add openjpeg. Remove libxp. [arguments]: In configure-flags disable scim, enable avahi, glib. Use setuid mount/umount binaries.
-rw-r--r--gnu/packages/enlightenment.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 4a65c55af9..a154c0403c 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
@@ -69,7 +69,7 @@
(define-public efl
(package
(name "efl")
- (version "1.23.3")
+ (version "1.24.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -77,7 +77,7 @@
version ".tar.xz"))
(sha256
(base32
- "00b9lp3h65254kdb1ys15fv7p3ln7qsvf15jkw4kli5ymagadkjk"))))
+ "1yhck2g4rwlzgnzqa4wjxw3lf6k6rd730hz4bwzajdjy7i26xfdk"))))
(build-system meson-build-system)
(native-inputs
`(("check" ,check)
@@ -93,6 +93,7 @@
("libraw" ,libraw)
("librsvg" ,librsvg)
("libspectre" ,libspectre)
+ ("libtiff" ,libtiff)
("libxau" ,libxau)
("libxcomposite" ,libxcomposite)
("libxcursor" ,libxcursor)
@@ -102,18 +103,18 @@
("libxi" ,libxi)
("libxfixes" ,libxfixes)
("libxinerama" ,libxinerama)
- ("libxp" ,libxp)
("libxrandr" ,libxrandr)
("libxrender" ,libxrender)
("libxss" ,libxscrnsaver)
("libxtst" ,libxtst)
+ ("libwebp" ,libwebp)
+ ("openjpeg" ,openjpeg)
("poppler" ,poppler)
("wayland-protocols" ,wayland-protocols)))
(propagated-inputs
;; All these inputs are in package config files in section
;; Requires.private.
`(("avahi" ,avahi)
- ("bullet" ,bullet)
("dbus" ,dbus)
("elogind" ,elogind)
("eudev" ,eudev)
@@ -122,15 +123,13 @@
("fribidi" ,fribidi)
("glib" ,glib)
("harfbuzz" ,harfbuzz)
- ("luajit" ,luajit)
("libinput" ,libinput-minimal)
("libjpeg" ,libjpeg)
- ("libpng" ,libpng)
("libsndfile" ,libsndfile)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
+ ("libpng" ,libpng)
("libx11" ,libx11)
("libxkbcommon" ,libxkbcommon)
+ ("luajit" ,luajit)
("lz4" ,lz4)
("openssl" ,openssl)
("pulseaudio" ,pulseaudio)
@@ -139,13 +138,18 @@
("zlib" ,zlib)))
(arguments
`(#:configure-flags '("-Dsystemd=false"
+ "-Delogind=true"
"-Dembedded-lz4=false"
"-Devas-loaders-disabler=json"
"-Dbuild-examples=false"
+ "-Decore-imf-loaders-disabler=scim"
+ "-Davahi=true"
+ "-Dglib=true"
+ "-Dmount-path=/run/setuid-programs/mount"
+ "-Dunmount-path=/run/setuid-programs/umount"
;(string-append "-Ddictionaries-hyphen-dir="
; (assoc-ref %build-inputs "hyphen")
; "/share/hyphen")
- "-Delogind=true"
"-Dnetwork-backend=connman"
,@(match (%current-system)
("armhf-linux"
@@ -153,8 +157,8 @@
(_
'("-Dopengl=full")))
;; for wayland
- "-Dwl-deprecated=true" ; ecore_wayland
- "-Ddrm-deprecated=true" ; ecore_drm
+ "-Dwl-deprecated=true" ; ecore_wayland
+ "-Ddrm-deprecated=true" ; ecore_drm
"-Dwl=true"
"-Ddrm=true")
#:tests? #f ; Many tests fail due to timeouts and network requests.