summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-30 20:01:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:49 +0200
commit8dd339e5a6f4a3bb1ee0060d1afdc258880878bd (patch)
treed582373f2e0b58eccac06c295ec02bd57c5d6c71
parent220b0ac38e3be153dfcca246c9a1d7ffaa9b8f7f (diff)
downloadpatches-8dd339e5a6f4a3bb1ee0060d1afdc258880878bd.tar
patches-8dd339e5a6f4a3bb1ee0060d1afdc258880878bd.tar.gz
gnu: python-six: Really enable tests.
* gnu/packages/python.scm (python-six)[arguments]: Override 'check' phase.
-rw-r--r--gnu/packages/python.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f76d655be6..a799226f5e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1178,6 +1178,12 @@ password storage.")
(base32
"0snmb8xffb3vsma0z67i0h0w2g2dy0p3gsgh9gi4i0kgc5l8spqh"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "py.test" "-v")))))))
(native-inputs
`(("python-py" ,python-py)
("python-pytest" ,python-pytest)))