summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-25 21:13:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-03-25 21:41:27 +0200
commit8778da03c8e82885a89faae13c4bd52a53afefd9 (patch)
tree5ce428f9cb3454b6f2e0e86b431915713240614e
parentc4f06c1164b2ce59fc601ad3f9ca86a4bdec96d4 (diff)
downloadpatches-8778da03c8e82885a89faae13c4bd52a53afefd9.tar
patches-8778da03c8e82885a89faae13c4bd52a53afefd9.tar.gz
gnu: Replace classpath-on-sablevm with classpath-0.99.
* gnu/packages/java.scm (classpath-on-sablevm): Replace with... (classpath-0.99): ...this new variable. (classpath-devel): Inherit from classpath-0.99.
-rw-r--r--gnu/packages/java.scm33
1 files changed, 11 insertions, 22 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 11a6480584..f3fe2b2d55 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -497,14 +497,11 @@ requirement for all GNU Classpath releases after version 0.93.")
compiler for Java} (ecj) with a command line interface that is compatible with
the standard javac executable.")))
-;; Note: All the tool wrappers (e.g. for javah, javac, etc) fail with
-;; java.lang.UnsupportedClassVersionError. They simply won't run on the old
-;; sablevm. We use Classpath 0.99 to build JamVM, on which the Classpath
-;; tools do run. Using these Classpath tools on JamVM we can then build the
-;; development version of GNU Classpath.
-(define classpath-on-sablevm
- (package
- (name "classpath")
+;; The classpath-bootstrap was built without a virtual machine, so it does not
+;; provide a wrapper for javah. We cannot build the development version of
+;; Classpath without javah.
+(define classpath-0.99
+ (package (inherit classpath-bootstrap)
(version "0.99")
(source (origin
(method url-fetch)
@@ -513,7 +510,6 @@ the standard javac executable.")))
(sha256
(base32
"1j7cby4k66f1nvckm48xcmh352b1d1b33qk7l6hi7dp9i9zjjagr"))))
- (build-system gnu-build-system)
(arguments
`(#:configure-flags
(list (string-append "--with-ecj-jar="
@@ -523,8 +519,8 @@ the standard javac executable.")))
(assoc-ref %build-inputs "ecj-javac-wrapper")
"/bin/javac")
(string-append "JAVA="
- (assoc-ref %build-inputs "sablevm")
- "/bin/java-sablevm")
+ (assoc-ref %build-inputs "jamvm")
+ "/bin/jamvm")
"GCJ_JAVAC_TRUE=no"
"ac_cv_prog_java_works=yes" ; trust me
"--disable-Werror"
@@ -543,17 +539,10 @@ the standard javac executable.")))
`(("ecj-bootstrap" ,ecj-bootstrap)
("ecj-javac-wrapper" ,ecj-javac-wrapper)
("fastjar" ,fastjar)
- ("sablevm" ,sablevm)
- ("sablevm-classpath" ,sablevm-classpath)
+ ("jamvm" ,jamvm-1-bootstrap)
+ ("classpath" ,classpath-bootstrap)
("libltdl" ,libltdl)
- ("pkg-config" ,pkg-config)))
- (home-page "https://www.gnu.org/software/classpath/")
- (synopsis "Essential libraries for Java")
- (description "GNU Classpath is a project to create core class libraries
-for use with runtimes, compilers and tools for the Java programming
-language.")
- ;; GPLv2 or later, with special linking exception.
- (license license:gpl2+)))
+ ("pkg-config" ,pkg-config)))))
(define jamvm-bootstrap
(package
@@ -720,7 +709,7 @@ the standard javac executable. The tool runs on JamVM instead of SableVM.")))
(define-public classpath-devel
(let ((commit "e7c13ee0cf2005206fbec0eca677f8cf66d5a103")
(revision "1"))
- (package (inherit classpath-on-sablevm)
+ (package (inherit classpath-bootstrap)
(version (string-append "0.99-" revision "." (string-take commit 9)))
(source (origin
(method git-fetch)