summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-04-20 23:56:14 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-02 16:49:29 +0200
commit7bb0ba81b394d82f56ee9d238919c7112e4666fd (patch)
treed660f0f2e7ce7f8d87e9b9d36838e01695b2a8f2
parentb1cb8b5d83dc92734840e9243d084c1c2a604321 (diff)
downloadpatches-7bb0ba81b394d82f56ee9d238919c7112e4666fd.tar
patches-7bb0ba81b394d82f56ee9d238919c7112e4666fd.tar.gz
gnu: nanovg-for-extempore: Update to 0.7.1-0.3c60175.
* gnu/packages/gl.scm (nanovg-for-extempore): Update to 0.7.1-0.3c60175. [source]: Switch to Git source to include latest changes. [version]: Use git-version. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gl.scm47
1 files changed, 26 insertions, 21 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01241cd88e..fd2e543461 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -742,30 +743,34 @@ and surfaces, receiving input and events.")
(license license:zlib)))
(define-public nanovg-for-extempore
- (package
- (name "nanovg-for-extempore")
- (version "0.7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/extemporelang/nanovg/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0ivs1sagq19xiw8jxd9f8w2b39svi0n9hrbmdvckwvqg95r8701g"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; no tests included
- (inputs
- `(("mesa" ,mesa)))
- ;; Extempore refuses to build on architectures other than x86_64
- (supported-systems '("x86_64-linux"))
- (home-page "https://github.com/extemporelang/nanovg")
- (synopsis "2D vector drawing library on top of OpenGL")
- (description "NanoVG is small antialiased vector graphics rendering
+ (let ((version "0.7.1")
+ (revision "0")
+ (commit "3c60175fcc2e5fe305b04355cdce35d499c80310"))
+ (package
+ (name "nanovg-for-extempore")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/extemporelang/nanovg.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ddn3d3mxqn8hj9967v3pss7lz1wn08pcdnqzc118g7yjkq7hxzy"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("mesa" ,mesa)))
+ ;; Extempore refuses to build on architectures other than x86_64
+ (supported-systems '("x86_64-linux"))
+ (home-page "https://github.com/extemporelang/nanovg")
+ (synopsis "2D vector drawing library on top of OpenGL")
+ (description "NanoVG is small antialiased vector graphics rendering
library for OpenGL. It has lean API modeled after HTML5 canvas API. It is
aimed to be a practical and fun toolset for building scalable user interfaces
and visualizations.")
- (license license:zlib)))
+ (license license:zlib))))
(define-public gl2ps
(package