summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-29 22:24:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-30 00:05:15 +0200
commit7b0e0fd5a2f963758d4c9161e9f2844e56289dad (patch)
treeb4e793ce399cb439fefec859435488bcdc56ad58
parent7fea8e076fd2405c0d53d7ee5d7a36936215ffcc (diff)
downloadpatches-7b0e0fd5a2f963758d4c9161e9f2844e56289dad.tar
patches-7b0e0fd5a2f963758d4c9161e9f2844e56289dad.tar.gz
gnu: python-flake8-2.5: Update to 2.6.2.
* gnu/packages/python-xyz.scm (python-flake8-2.5): Update to 2.6.2; rename it... (python-flake8-2.6): ...to this. [arguments]: Add phase "use-later-pycodestyles", and move "check" phase after "install". [propagated-inputs]: Explicitly list python-pycodestyle, python-entrypoints, python-pyflakes-1.2, and python-mccabe.
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 24 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1110360afd..0f4351d152 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7506,20 +7506,39 @@ complexity of Python source code.")
("python2-typing" ,python2-typing)
,@(package-propagated-inputs base))))))
-;; python-hacking requires flake8 <2.6.0.
-(define-public python-flake8-2.5
+;; python-hacking requires flake8 <2.7.0.
+(define-public python-flake8-2.6
(package
(inherit python-flake8)
- (version "2.5.5")
+ (version "2.6.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "1snylqwbmrylbx3r1wpz8ggk98f6bcag4441ag8mm2l7wyn58sij"))))
+ "0y57hzal0j84dh9i1g1g6dc4aywvrnhy2fjmmbglpv5ajihxh713"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-later-pycodestyles
+ (lambda __
+ (substitute* '("flake8.egg-info/requires.txt"
+ "setup.py")
+ (("pycodestyle >= 2.0, < 2.1")
+ "pycodestyle >= 2.0"))
+ #t))
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v")
+ #t)))))
(propagated-inputs
`(("python-pep8" ,python-pep8)
- ,@(package-propagated-inputs python-flake8)))))
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-entrypoints" ,python-entrypoints)
+ ("python-pyflakes" ,python-pyflakes-1.2)
+ ("python-mccabe" ,python-mccabe)))))
(define-public python-flake8-polyfill
(package