summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 11:29:16 +0100
commit2d321bb2c572ca91830da2790aa6883e6218b42a (patch)
tree8bb3da4582405f4717c2f1eacbbe2503ac8ac0ff
parent8ee62c97f659c6b288c76efe621969b9535a3542 (diff)
downloadpatches-2d321bb2c572ca91830da2790aa6883e6218b42a.tar
patches-2d321bb2c572ca91830da2790aa6883e6218b42a.tar.gz
gnu: Add python-nbformat.
* gnu/packages/python.scm (python-nbformat, python2-nbformat): New variables.
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5234dba2d2..28b38cfae6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6664,6 +6664,35 @@ Debian-related files, such as:
(define-public python2-debian
(package-with-python2 python-debian))
+(define-public python-nbformat
+ (package
+ (name "python-nbformat")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nbformat" version))
+ (sha256
+ (base32
+ "0mq8iki3d4mnx7wy05phss7x98mds4fqydin8lcagidp1knw1xnv"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f)) ; no test target
+ (propagated-inputs
+ `(("python-ipython-genutils" ,python-ipython-genutils)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-jupyter-core" ,python-jupyter-core)
+ ("python-traitlets" ,python-traitlets)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://jupyter.org")
+ (synopsis "Jupyter Notebook format")
+ (description "This package provides the reference implementation of the
+Jupyter Notebook format and Python APIs for working with notebooks.")
+ (license license:bsd-3)))
+
+(define-public python2-nbformat
+ (package-with-python2 python-nbformat))
+
(define-public python-chardet
(package
(name "python-chardet")