summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>2020-05-02 03:14:36 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-05-02 12:04:57 +0200
commit15c6e4260b60135025029a5e2695206e798c9dd6 (patch)
treeddb16f8ff30a29e7df86d858a1d2f2e656861ec9
parent218ec70aee2476b3381d18f7394ed1c37c0f7a8c (diff)
downloadpatches-15c6e4260b60135025029a5e2695206e798c9dd6.tar
patches-15c6e4260b60135025029a5e2695206e798c9dd6.tar.gz
gnu: telephony: Move Jami and its dependencies to jami.scm.
Jami is a massive package and its developers modify many libraries. Keeping them in a single file makes maintenance easier. * gnu/packages/telephony.scm (%jami-version, jami-source, pjproject-jami, libring, libringclient, jami, jami-client-gnome): Move to ... * gnu/packages/jami.scm: ... this new file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/jami.scm352
-rw-r--r--gnu/packages/telephony.scm291
3 files changed, 354 insertions, 291 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 26d26ee215..812253b192 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -33,6 +33,7 @@
# Copyright © 2020 Michael Rohleder <mike@rohleder.de>
# Copyright © 2020 Felix Gruber <felgru@posteo.net>
# Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+# Copyright © 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
#
# This file is part of GNU Guix.
#
@@ -278,6 +279,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/ipfs.scm \
%D%/packages/irc.scm \
%D%/packages/iso-codes.scm \
+ %D%/packages/jami.scm \
%D%/packages/java.scm \
%D%/packages/java-compression.scm \
%D%/packages/java-graphics.scm \
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
new file mode 100644
index 0000000000..050f8cf9f6
--- /dev/null
+++ b/gnu/packages/jami.scm
@@ -0,0 +1,352 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2019, 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages jami)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages aidc)
+ #:use-module (gnu packages audio)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages crypto)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages networking)
+ #:use-module (gnu packages pcre)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages serialization)
+ #:use-module (gnu packages sqlite)
+ #:use-module (gnu packages telephony)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages upnp)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages webkit)
+ #:use-module (gnu packages xiph)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define %jami-version "20191101.3.67671e7")
+
+(define* (jami-source #:key without-daemon)
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.jami.net/ring-release/tarballs/ring_"
+ %jami-version
+ ".tar.gz"))
+ (modules '((guix build utils)))
+ (snippet
+ (if without-daemon
+ '(begin
+ (delete-file-recursively "daemon/contrib"))
+ #f))
+ (sha256
+ (base32
+ "0kw172w2ccyz438kf5xqw14nhfm4xk6a2libnzib9j2wvhlpf4q0"))))
+
+(define-public pjproject-jami
+ (package
+ (inherit pjproject)
+ (name "pjproject-jami")
+ (native-inputs
+ `(("savoir-faire-linux-patches" ,(jami-source))
+ ,@(package-native-inputs pjproject)))
+ (arguments
+ `(#:tests? #f
+ ;; See ring-project/daemon/contrib/src/pjproject/rules.mak.
+ #:configure-flags
+ (list "--disable-oss"
+ "--disable-sound"
+ "--disable-video"
+ "--enable-ext-sound"
+ "--disable-speex-aec"
+ "--disable-g711-codec"
+ "--disable-l16-codec"
+ "--disable-gsm-codec"
+ "--disable-g722-codec"
+ "--disable-g7221-codec"
+ "--disable-speex-codec"
+ "--disable-ilbc-codec"
+ "--disable-opencore-amr"
+ "--disable-silk"
+ "--disable-sdl"
+ "--disable-ffmpeg"
+ "--disable-v4l2"
+ "--disable-openh264"
+ "--disable-resample"
+ "--disable-libwebrtc"
+ "--with-gnutls"
+ "--with-external-srtp"
+ ;; We need -fPIC or else we get the following error when linking
+ ;; against pjproject-jami:
+ ;; relocation R_X86_64_32S against `.rodata' can not be used when
+ ;; making a shared object;
+ "CFLAGS=-fPIC"
+ "CXXFLAGS=-fPIC")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
+ (add-after 'unpack 'apply-patches
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((savoir-faire-linux-patches-directory "Savoir-faire Linux patches")
+ ;; Comes from
+ ;; "ring-project/daemon/contrib/src/pjproject/rules.mak".
+ ;; WARNING: These amount for huge changes in pjproject.
+ (savoir-faire-linux-patches
+ '("fix_turn_alloc_failure"
+ "rfc2466"
+ "ipv6"
+ "multiple_listeners"
+ "pj_ice_sess"
+ "fix_turn_fallback"
+ "fix_ioqueue_ipv6_sendto"
+ "add_dtls_transport"
+ "rfc6544"
+ "ice_config"
+ "sip_config"
+ "fix_first_packet_turn_tcp"
+ "fix_ebusy_turn"
+ "ignore_ipv6_on_transport_check"
+ "fix_turn_connection_failure"
+ ;; "uwp_vs" ; for windows
+ "disable_local_resolution")))
+ (mkdir-p savoir-faire-linux-patches-directory)
+ (invoke "tar" "-xvf" (assoc-ref inputs "savoir-faire-linux-patches")
+ "-C" savoir-faire-linux-patches-directory
+ "--strip-components=5"
+ "ring-project/daemon/contrib/src/pjproject")
+ (for-each
+ (lambda (file)
+ (invoke "patch" "--force" "-p1" "-i"
+ (string-append savoir-faire-linux-patches-directory "/"
+ file ".patch")))
+ savoir-faire-linux-patches))
+ #t))
+ ;; TODO: We could use substitute-keyword-arguments instead of
+ ;; repeating the phases from pjproject, but somehow it does
+ ;; not work.
+ (add-before 'build 'build-dep
+ (lambda _ (invoke "make" "dep")))
+ (add-before 'patch-source-shebangs 'autoconf
+ (lambda _
+ (invoke "autoconf" "-v" "-f" "-i" "-o"
+ "aconfigure" "aconfigure.ac")))
+ (add-before 'autoconf 'disable-some-tests
+ ;; Three of the six test programs fail due to missing network
+ ;; access.
+ (lambda _
+ (substitute* "Makefile"
+ (("selftest: pjlib-test pjlib-util-test pjnath-test pjmedia-test pjsip-test pjsua-test")
+ "selftest: pjlib-test pjlib-util-test pjmedia-test"))
+ #t)))))))
+
+(define-public libring
+ (package
+ (name "libring")
+ (version %jami-version)
+ (source (jami-source #:without-daemon #t))
+ (build-system gnu-build-system)
+ (inputs
+ ;; Missing (optional?) dep: libnatpmp.
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("dbus-c++" ,dbus-c++)
+ ("eudev" ,eudev)
+ ("ffmpeg" ,ffmpeg)
+ ("flac" ,flac)
+ ("gmp" ,gmp)
+ ("gsm" ,gsm)
+ ("jack" ,jack-1)
+ ("jsoncpp" ,jsoncpp)
+ ("libogg" ,libogg)
+ ("libva" ,libva)
+ ("opendht" ,opendht)
+ ("opus" ,opus)
+ ("pcre" ,pcre)
+ ("pulseaudio" ,pulseaudio)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("speex" ,speex)
+ ("speexdsp" ,speexdsp)
+ ("libupnp" ,libupnp)
+ ("libvorbis" ,libvorbis)
+ ("libx264" ,libx264)
+ ("libvdpau" ,libvdpau)
+ ("yaml-cpp" ,yaml-cpp)
+ ("zlib" ,zlib)
+ ("openssl" ,openssl)
+ ("libsecp256k1" ,libsecp256k1)
+ ("python" ,python)
+ ("python-wrapper" ,python-wrapper)
+ ("restinio" ,restinio)
+ ("libx11" ,libx11)
+ ("asio" ,asio)
+ ;; TODO: Upstream seems to rely on a custom pjproject (a.k.a. pjsip) version.
+ ;; See https://git.jami.net/savoirfairelinux/ring-daemon/issues/24.
+ ("pjproject" ,pjproject-jami)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)
+ ("cppunit" ,cppunit)
+ ("perl" ,perl))) ; Needed for documentation.
+ (arguments
+ `(#:tests? #f ; The tests fail to compile due to missing headers.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "daemon")
+ #t))
+ (add-before 'build 'add-lib-dir
+ (lambda _
+ (mkdir-p "src/lib")
+ #t)))))
+ (synopsis "Distributed multimedia communications platform")
+ (description "Jami (formerly GNU Ring) is a secure and distributed voice,
+video and chat communication platform that requires no centralized server and
+leaves the power of privacy in the hands of the user. It supports the SIP and
+IAX protocols, as well as decentralized calling using P2P-DHT.
+
+This package provides a library and daemon implementing the Jami core
+functionality.")
+ (home-page "https://jami.net/")
+ (license license:gpl3+)))
+
+(define-public libringclient
+ (package
+ (inherit libring)
+ (name "libringclient")
+ (build-system cmake-build-system)
+ (propagated-inputs
+ `(("libring" ,libring) ; For 'dring'.
+ ("qtbase" ,qtbase) ; Qt is included in several installed headers.
+ ("qttools" ,qttools)))
+ (arguments
+ `(#:tests? #f ; There is no testsuite.
+ #:configure-flags
+ (list (string-append "-DRING_BUILD_DIR="
+ (assoc-ref %build-inputs "libring") "/include"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "lrc")
+ #t))
+ (add-before 'configure 'fix-dbus-interfaces-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{CMAKE_INSTALL_PREFIX\\}(/share/dbus-1/interfaces)" _ dbus-interfaces-path-suffix)
+ (string-append (assoc-ref inputs "libring")
+ dbus-interfaces-path-suffix))))))))
+ (synopsis "Distributed multimedia communications platform")
+ (description "Jami (formerly GNU Ring) is a secure and distributed voice,
+video and chat communication platform that requires no centralized server and
+leaves the power of privacy in the hands of the user. It supports the SIP and
+IAX protocols, as well as decentralized calling using P2P-DHT.
+
+This package provides a library common to all Jami clients.")
+ (home-page "https://jami.net")
+ (license license:gpl3+)))
+
+(define-public jami
+ (package
+ (inherit libring)
+ (name "jami")
+ (build-system cmake-build-system)
+ (inputs
+ `(("libringclient" ,libringclient)
+ ("gtk+" ,gtk+)
+ ("qrencode" ,qrencode)
+ ("libnotify" ,libnotify)
+ ("clutter" ,clutter)
+ ("clutter-gtk" ,clutter-gtk)
+ ("gettext" ,gnu-gettext)
+ ("libcanberra" ,libcanberra)
+ ("webkitgtk" ,webkitgtk)
+ ;; TODO: We must wrap ring-client-gnome to force using the
+ ;; `sqlite-with-column-metadata' package instead of `sqlite' or else it
+ ;; fails with:
+ ;;
+ ;; /gnu/store/...-qtbase-5.11.2/lib/qt5/plugins/sqldrivers/libqsqlite.so:
+ ;; undefined symbol: sqlite3_column_table_name16
+ ;;
+ ;; qtbase is built against sqlite-with-column-metadata but somehow
+ ;; jami-client-gnome ends up with both `sqlite' and
+ ;; `sqlite-with-column-metadata' as inputs and it seems that
+ ;; libqsqlite.so gets confused.
+ ("sqlite" ,sqlite-with-column-metadata)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin")
+ ("doxygen" ,doxygen)))
+ (propagated-inputs
+ `(("libring" ,libring) ; Contains `dring', the daemon, which is automatically by d-bus.
+ ("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("evolution-data-server" ,evolution-data-server)))
+ (arguments
+ `(#:tests? #f ; There is no testsuite.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "client-gnome")
+ #t))
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (path (string-append (assoc-ref inputs "sqlite") "/lib")))
+ (wrap-program (string-append out "/bin/jami-gnome")
+ `("LD_LIBRARY_PATH" ":" prefix (,path))))
+ #t)))))
+ (synopsis "Distributed, privacy-respecting communication program")
+ (description "Jami (formerly GNU Ring) is a secure and distributed voice,
+video and chat communication platform that requires no centralized server and
+leaves the power of privacy in the hands of the user. It supports the SIP and
+IAX protocols, as well as decentralized calling using P2P-DHT.
+
+This package provides the Jami client for the GNOME desktop.")
+ (home-page "https://jami.net")
+ (license license:gpl3+)))
+
+(define-public jami-client-gnome
+ (deprecated-package "jami-client-gnome" jami))
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 7b20954120..747b0d75a1 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -734,297 +734,6 @@ calls and messages")
Initiation Protocol (SIP) and a multimedia framework.")
(license license:gpl2+)))
-(define %jami-version "20191101.3.67671e7")
-
-(define* (jami-source #:key without-daemon)
- (origin
- (method url-fetch)
- (uri (string-append "https://dl.jami.net/ring-release/tarballs/ring_"
- %jami-version
- ".tar.gz"))
- (modules '((guix build utils)))
- (snippet
- (if without-daemon
- '(begin
- (delete-file-recursively "daemon/contrib"))
- #f))
- (sha256
- (base32
- "0kw172w2ccyz438kf5xqw14nhfm4xk6a2libnzib9j2wvhlpf4q0"))))
-
-(define-public pjproject-jami
- (package
- (inherit pjproject)
- (name "pjproject-jami")
- (native-inputs
- `(("savoir-faire-linux-patches" ,(jami-source))
- ,@(package-native-inputs pjproject)))
- (arguments
- `(#:tests? #f
- ;; See ring-project/daemon/contrib/src/pjproject/rules.mak.
- #:configure-flags
- (list "--disable-oss"
- "--disable-sound"
- "--disable-video"
- "--enable-ext-sound"
- "--disable-speex-aec"
- "--disable-g711-codec"
- "--disable-l16-codec"
- "--disable-gsm-codec"
- "--disable-g722-codec"
- "--disable-g7221-codec"
- "--disable-speex-codec"
- "--disable-ilbc-codec"
- "--disable-opencore-amr"
- "--disable-silk"
- "--disable-sdl"
- "--disable-ffmpeg"
- "--disable-v4l2"
- "--disable-openh264"
- "--disable-resample"
- "--disable-libwebrtc"
- "--with-gnutls"
- "--with-external-srtp"
- ;; We need -fPIC or else we get the following error when linking
- ;; against pjproject-jami:
- ;; relocation R_X86_64_32S against `.rodata' can not be used when
- ;; making a shared object;
- "CFLAGS=-fPIC"
- "CXXFLAGS=-fPIC")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t))
- (add-after 'unpack 'apply-patches
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((savoir-faire-linux-patches-directory "Savoir-faire Linux patches")
- ;; Comes from
- ;; "ring-project/daemon/contrib/src/pjproject/rules.mak".
- ;; WARNING: These amount for huge changes in pjproject.
- (savoir-faire-linux-patches
- '("fix_turn_alloc_failure"
- "rfc2466"
- "ipv6"
- "multiple_listeners"
- "pj_ice_sess"
- "fix_turn_fallback"
- "fix_ioqueue_ipv6_sendto"
- "add_dtls_transport"
- "rfc6544"
- "ice_config"
- "sip_config"
- "fix_first_packet_turn_tcp"
- "fix_ebusy_turn"
- "ignore_ipv6_on_transport_check"
- "fix_turn_connection_failure"
- ;; "uwp_vs" ; for windows
- "disable_local_resolution")))
- (mkdir-p savoir-faire-linux-patches-directory)
- (invoke "tar" "-xvf" (assoc-ref inputs "savoir-faire-linux-patches")
- "-C" savoir-faire-linux-patches-directory
- "--strip-components=5"
- "ring-project/daemon/contrib/src/pjproject")
- (for-each
- (lambda (file)
- (invoke "patch" "--force" "-p1" "-i"
- (string-append savoir-faire-linux-patches-directory "/"
- file ".patch")))
- savoir-faire-linux-patches))
- #t))
- ;; TODO: We could use substitute-keyword-arguments instead of
- ;; repeating the phases from pjproject, but somehow it does
- ;; not work.
- (add-before 'build 'build-dep
- (lambda _ (invoke "make" "dep")))
- (add-before 'patch-source-shebangs 'autoconf
- (lambda _
- (invoke "autoconf" "-v" "-f" "-i" "-o"
- "aconfigure" "aconfigure.ac")))
- (add-before 'autoconf 'disable-some-tests
- ;; Three of the six test programs fail due to missing network
- ;; access.
- (lambda _
- (substitute* "Makefile"
- (("selftest: pjlib-test pjlib-util-test pjnath-test pjmedia-test pjsip-test pjsua-test")
- "selftest: pjlib-test pjlib-util-test pjmedia-test"))
- #t)))))))
-
-(define-public libring
- (package
- (name "libring")
- (version %jami-version)
- (source (jami-source #:without-daemon #t))
- (build-system gnu-build-system)
- (inputs
- ;; Missing (optional?) dep: libnatpmp.
- `(("alsa-lib" ,alsa-lib)
- ("boost" ,boost)
- ("dbus-c++" ,dbus-c++)
- ("eudev" ,eudev)
- ("ffmpeg" ,ffmpeg)
- ("flac" ,flac)
- ("gmp" ,gmp)
- ("gsm" ,gsm)
- ("jack" ,jack-1)
- ("jsoncpp" ,jsoncpp)
- ("libogg" ,libogg)
- ("libva" ,libva)
- ("opendht" ,opendht)
- ("opus" ,opus)
- ("pcre" ,pcre)
- ("pulseaudio" ,pulseaudio)
- ("libsamplerate" ,libsamplerate)
- ("libsndfile" ,libsndfile)
- ("speex" ,speex)
- ("speexdsp" ,speexdsp)
- ("libupnp" ,libupnp)
- ("libvorbis" ,libvorbis)
- ("libx264" ,libx264)
- ("libvdpau" ,libvdpau)
- ("yaml-cpp" ,yaml-cpp)
- ("zlib" ,zlib)
- ("openssl" ,openssl)
- ("libsecp256k1" ,libsecp256k1)
- ("python" ,python)
- ("python-wrapper" ,python-wrapper)
- ("restinio" ,restinio)
- ("libx11" ,libx11)
- ("asio" ,asio)
- ;; TODO: Upstream seems to rely on a custom pjproject (a.k.a. pjsip) version.
- ;; See https://git.jami.net/savoirfairelinux/ring-daemon/issues/24.
- ("pjproject" ,pjproject-jami)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("which" ,which)
- ("cppunit" ,cppunit)
- ("perl" ,perl))) ; Needed for documentation.
- (arguments
- `(#:tests? #f ; The tests fail to compile due to missing headers.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "daemon")
- #t))
- (add-before 'build 'add-lib-dir
- (lambda _
- (mkdir-p "src/lib")
- #t)))))
- (synopsis "Distributed multimedia communications platform")
- (description "Jami (formerly GNU Ring) is a secure and distributed voice,
-video and chat communication platform that requires no centralized server and
-leaves the power of privacy in the hands of the user. It supports the SIP and
-IAX protocols, as well as decentralized calling using P2P-DHT.
-
-This package provides a library and daemon implementing the Jami core
-functionality.")
- (home-page "https://jami.net/")
- (license license:gpl3+)))
-
-(define-public libringclient
- (package
- (inherit libring)
- (name "libringclient")
- (build-system cmake-build-system)
- (propagated-inputs
- `(("libring" ,libring) ; For 'dring'.
- ("qtbase" ,qtbase) ; Qt is included in several installed headers.
- ("qttools" ,qttools)))
- (arguments
- `(#:tests? #f ; There is no testsuite.
- #:configure-flags
- (list (string-append "-DRING_BUILD_DIR="
- (assoc-ref %build-inputs "libring") "/include"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "lrc")
- #t))
- (add-before 'configure 'fix-dbus-interfaces-path
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "CMakeLists.txt"
- (("\\$\\{CMAKE_INSTALL_PREFIX\\}(/share/dbus-1/interfaces)" _ dbus-interfaces-path-suffix)
- (string-append (assoc-ref inputs "libring")
- dbus-interfaces-path-suffix))))))))
- (synopsis "Distributed multimedia communications platform")
- (description "Jami (formerly GNU Ring) is a secure and distributed voice,
-video and chat communication platform that requires no centralized server and
-leaves the power of privacy in the hands of the user. It supports the SIP and
-IAX protocols, as well as decentralized calling using P2P-DHT.
-
-This package provides a library common to all Jami clients.")
- (home-page "https://jami.net")
- (license license:gpl3+)))
-
-(define-public jami
- (package
- (inherit libring)
- (name "jami")
- (build-system cmake-build-system)
- (inputs
- `(("libringclient" ,libringclient)
- ("gtk+" ,gtk+)
- ("qrencode" ,qrencode)
- ("libnotify" ,libnotify)
- ("clutter" ,clutter)
- ("clutter-gtk" ,clutter-gtk)
- ("libcanberra" ,libcanberra)
- ("webkitgtk" ,webkitgtk)
- ;; TODO: We must wrap ring-client-gnome to force using the
- ;; `sqlite-with-column-metadata' package instead of `sqlite' or else it
- ;; fails with:
- ;;
- ;; /gnu/store/...-qtbase-5.11.2/lib/qt5/plugins/sqldrivers/libqsqlite.so:
- ;; undefined symbol: sqlite3_column_table_name16
- ;;
- ;; qtbase is built against sqlite-with-column-metadata but somehow
- ;; jami-client-gnome ends up with both `sqlite' and
- ;; `sqlite-with-column-metadata' as inputs and it seems that
- ;; libqsqlite.so gets confused.
- ("sqlite" ,sqlite-with-column-metadata)))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("doxygen" ,doxygen)))
- (propagated-inputs
- `(("libring" ,libring) ; Contains `dring', the daemon, which is automatically by d-bus.
- ("adwaita-icon-theme" ,adwaita-icon-theme)
- ("evolution-data-server" ,evolution-data-server)))
- (arguments
- `(#:tests? #f ; There is no testsuite.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "client-gnome")
- #t))
- (add-after 'install 'wrap
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (path (string-append (assoc-ref inputs "sqlite") "/lib")))
- (wrap-program (string-append out "/bin/jami-gnome")
- `("LD_LIBRARY_PATH" ":" prefix (,path))))
- #t)))))
- (synopsis "Distributed, privacy-respecting communication program")
- (description "Jami (formerly GNU Ring) is a secure and distributed voice,
-video and chat communication platform that requires no centralized server and
-leaves the power of privacy in the hands of the user. It supports the SIP and
-IAX protocols, as well as decentralized calling using P2P-DHT.
-
-This package provides the Jami client for the GNOME desktop.")
- (home-page "https://jami.net")
- (license license:gpl3+)))
-
-(define-public jami-client-gnome
- (deprecated-package "jami-client-gnome" jami))
-
(define-public libtgvoip
(package
(name "libtgvoip")