summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-02-20 17:00:27 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-20 17:01:56 +0100
commit0d5c5b1b6475c04ba6becbbeb44775f0d981ef15 (patch)
tree85950a6eee979286bd89521a00da10168b93dc86
parent78b2eb1ad3dcf05c25e0ee4980c97aa52de03a2d (diff)
downloadpatches-0d5c5b1b6475c04ba6becbbeb44775f0d981ef15.tar
patches-0d5c5b1b6475c04ba6becbbeb44775f0d981ef15.tar.gz
gnu: fakeroot: Enable ACL support.
* gnu/packages/linux.scm (fakeroot)[native-inputs]: Add acl. [arguments]<#:phases>[setenv]: New phase.
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8b86531196..ad7ee2ac4e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5096,6 +5096,10 @@ the superuser to make device nodes.")
(string-append (assoc-ref inputs "util-linux")
"/bin/getopt")))
#t))
+ (add-before 'configure 'setenv
+ (lambda _
+ (setenv "LIBS" "-lacl")
+ #t))
(add-before 'check 'prepare-check
(lambda _
(setenv "SHELL" (which "bash"))
@@ -5114,7 +5118,8 @@ the superuser to make device nodes.")
(("tar -tvf") "tar --numeric-owner -tvf"))
#t)))))
(native-inputs
- `(("sharutils" ,sharutils) ; for the tests
+ `(("acl" ,acl)
+ ("sharutils" ,sharutils) ; for the tests
("xz" ,xz))) ; for the tests
(inputs
`(("libcap" ,libcap)