summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Frederickson <jonathan@terracrypt.net>2020-04-30 20:58:01 -0400
committerLeo Famulari <leo@famulari.name>2020-05-01 17:30:16 -0400
commitecd56cd1b223733c3ec04043fec245acf4c1cdb8 (patch)
tree4a897db40278d339fcae82d5aa31d64e11f64807
parent934f0b32cfacd0bc05e79e54ffbc3bc253a0eb2d (diff)
downloadpatches-ecd56cd1b223733c3ec04043fec245acf4c1cdb8.tar
patches-ecd56cd1b223733c3ec04043fec245acf4c1cdb8.tar.gz
gnu: Add ladspa-bs2b
* gnu/packages/audio.scm (ladspa-bs2b): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/audio.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e2e276723b..f518fb7f21 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1855,6 +1856,31 @@ for headphone prolonged listening to disable superstereo fatigue without
essential distortions.")
(license license:expat)))
+(define-public ladspa-bs2b
+ (package
+ (name "ladspa-bs2b")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/bs2b/plugins/LADSPA%20plugin/"
+ version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b4aipbj1ba5k99gbc7gmgy14sywyrjd8rpyqj5l905j0mjv8jg2"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("ladspa" ,ladspa)
+ ("libbs2b" ,libbs2b)))
+ (home-page "https://sourceforge.net/projects/bs2b/")
+ (synopsis "Bauer stereophonic-to-binaural DSP - LADSPA plugin")
+ (description "The Bauer stereophonic-to-binaural DSP (bs2b) library and
+plugins is designed to improve headphone listening of stereo audio records.
+Recommended for headphone prolonged listening to disable superstereo fatigue
+without essential distortions. This package contains a LADSPA plugin for use
+with applications that support them (e.g. PulseAudio).")
+ (license license:gpl2+)))
+
(define-public liblo
(package
(name "liblo")