summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-14 10:02:11 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-14 18:00:32 +0200
commitb0cf64c0bc493164515b5a09724c2dd3d3abf511 (patch)
tree8d7bd2c8f447446542dff5ec976d5730d3706854
parent6078c0043dc5a2e17c199a7a3d03d4cdb4b766ee (diff)
downloadpatches-b0cf64c0bc493164515b5a09724c2dd3d3abf511.tar
patches-b0cf64c0bc493164515b5a09724c2dd3d3abf511.tar.gz
gnu: Add emacs-sly-named-readtables.
* gnu/packages/emacs-xyz.scm (emacs-sly-named-readtables): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e97571bf9f..ed3d2d43e8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7077,6 +7077,35 @@ sly-quickload command that prompts the user for a package to install. ")
additional support for working with ASDF projects.")
(license license:gpl3+))))
+(define-public emacs-sly-named-readtables
+ (let ((commit "a5a42674ccffa97ccd5e4e9742beaf3ea719931f")
+ (revision "1"))
+ (package
+ (name "emacs-sly-named-readtables")
+ (version (git-version "0.1" revision commit))
+ (home-page "https://github.com/joaotavora/sly-named-readtables")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16asd119rzqrlclps2q6yrkis8jy5an5xgzzqvb7jdyq39zxg54q"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-sly" ,emacs-sly)))
+ (arguments
+ '(#:include (cons* "\\.lisp$" "\\.asd$" %default-include)))
+ (synopsis "Named-readtables support for SLY")
+ (description
+ "@command{sly-named-readtables} is an external contrib for SLY that
+enables different readtables to be active in different parts of the same
+file.")
+ (license license:gpl3+))))
+
(define-public emacs-lua-mode
(let ((commit "95c64bb5634035630e8c59d10d4a1d1003265743")
(revision "2"))