summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2020-04-30 18:46:30 +0000
committerVagrant Cascadian <vagrant@debian.org>2020-04-30 13:13:07 -0700
commitac4fefb2983aff5e5972b4279aee5296a08aab6a (patch)
treea157266c6201d9e64a3a5748442f970eabaa58b5
parent2a94f72adef710af481a5abefdddb6cde04b5526 (diff)
downloadpatches-ac4fefb2983aff5e5972b4279aee5296a08aab6a.tar
patches-ac4fefb2983aff5e5972b4279aee5296a08aab6a.tar.gz
gnu: diffoscope: Update to 143.
* gnu/packages/diffoscope (diffoscope): Update to 143. [native-inputs]: Add openssl and python-h5py. [arguments] Add openssl to add-known-tools phase. [arguments] Remove hdf5 from add-known-tools phase, added upstream.
-rw-r--r--gnu/packages/diffoscope.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 71c0039dfb..1df8552a30 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages ssh)
#:use-module (gnu packages statistics)
#:use-module (gnu packages textutils)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages vim)
#:use-module (gnu packages web)
@@ -69,7 +70,7 @@
#:use-module (ice-9 match))
(define-public diffoscope
- (let ((version "141"))
+ (let ((version "143"))
(package
(name "diffoscope")
(version version)
@@ -81,7 +82,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0pls2jryx394ysaz0g8h959lhrsdqak9bkxjd5r6sdckgiikplkj"))))
+ "0j58dqdk8ln8y0bcnfy37ljs37nkl56lzxqns396300ysln0qiwm"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -96,8 +97,8 @@
(add-after 'unpack 'add-known-tools
(lambda _
(substitute* "diffoscope/external_tools.py"
- (("'debian': 'hdf5-tools'")
- "'debian': 'hdf5-tools', 'guix': 'hdf5'"))))
+ (("'debian': 'openssl'")
+ "'debian': 'openssl', 'guix': 'openssl'"))))
;; This test is broken because our `file` package has a
;; bug in berkeley-db file type detection.
(add-after 'unpack 'remove-berkeley-test
@@ -161,6 +162,7 @@
(native-inputs `(("python-pytest" ,python-pytest)
("python-chardet" ,python-chardet)
("python-binwalk" ,python-binwalk)
+ ("python-h5py" ,python-h5py)
("python-pypdf2" ,python-pypdf2)
("python-progressbar33" ,python-progressbar33)
;; test suite skips tests when tool is missing
@@ -205,6 +207,7 @@
("ocaml" ,ocaml)
("odt2txt" ,odt2txt)
("openssh" ,openssh)
+ ("openssl" ,openssl)
("pgpdump" ,pgpdump)
("poppler" ,poppler)
("python-jsbeautifier" ,python-jsbeautifier)