summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-08-14 18:50:36 +0200
committerLudovic Courtès <ludo@gnu.org>2012-08-14 18:50:36 +0200
commit437e0729d86e750bed5ca76307e5dad610a337e6 (patch)
tree7df263e0c07580270b88315609ff07187409dc2c
parentd95c0113c9f13365bcd2e95b0e2beb125281a67a (diff)
downloadpatches-437e0729d86e750bed5ca76307e5dad610a337e6.tar
patches-437e0729d86e750bed5ca76307e5dad610a337e6.tar.gz
build: Pass the right flags for "make distcheck".
* Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): New variable. * configure.ac: Define and substitute `NIX_PREFIX'.
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac6
2 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a55de7bd38..18ebd658e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,3 +95,5 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
SUBDIRS = po
ACLOCAL_AMFLAGS = -I m4
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --with-nixpkgs=$(NIXPKGS) --with-nix-prefix="$(NIX_PREFIX)"
diff --git a/configure.ac b/configure.ac
index d8537294c5..aed8287bfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,11 @@ AC_ARG_WITH([nix-prefix],
[AS_HELP_STRING([--with-nix-prefix=DIR], [search for Nix in DIR])],
[case "$withval" in
yes|no) ;;
- *) PATH="$withval/bin:$PATH"; export PATH;;
+ *)
+ NIX_PREFIX="$withval"
+ PATH="$NIX_PREFIX/bin:$PATH"; export PATH
+ AC_SUBST([NIX_PREFIX])
+ ;;
esac],
[])