summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-30 16:56:44 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-30 16:57:40 +0200
commit192177b04974f456a081e7cb9177e7d9147f822c (patch)
treedd9407c237a326a5b8fd6225cd58932a607a7aea
parent24599740e7e0910fdc2b859d2e0eff0411abbc3a (diff)
downloadpatches-192177b04974f456a081e7cb9177e7d9147f822c.tar
patches-192177b04974f456a081e7cb9177e7d9147f822c.tar.gz
gnu: sbcl-osicat: Fix library path.
* gnu/packages/lisp-xyz.scm (sbcl-osicat)[arguments]: Replace 'cleanup phase to preserve the location of libosicat.so so that it can be found when loading the system.
-rw-r--r--gnu/packages/lisp-xyz.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c2029d940e..b032346a30 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11533,21 +11533,19 @@ MOP easier to use.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'validate-runpath 'cleanup-files
+ ;; The cleanup phase moves files around but we need to keep the
+ ;; directory structure for the grovel-generated library.
+ (replace 'cleanup
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/sbcl")))
- (for-each
- delete-file
- (filter (lambda (file)
- (not (member (basename file)
- '("basic-unixint__grovel"
- "libosicat.so"
- "osicat--system.fasl"
- "osicat.asd"
- "unixint__grovel"))))
- (find-files lib ".*")))
- #t))))))
+ (lib (string-append out "/lib/sbcl/")))
+ (delete-file-recursively (string-append lib "src"))
+ (delete-file-recursively (string-append lib "tests"))
+ (for-each delete-file
+ (filter (lambda (file)
+ (not (member (basename file) '("libosicat.so"))))
+ (find-files (string-append lib "posix") ".*"))))
+ #t)))))
(inputs
`(("alexandria" ,sbcl-alexandria)
("cffi" ,sbcl-cffi)